Gem installation issue

Hello,

I’m running with my head against the wall here. I’m trying to create a
new Ruby environment on my laptop from work, which is a Window 7 system
and inside the domain of the company.

I’ve downloaded the Ruby 1.9.2 Windows installer and installed it to
C:\Ruby\1.9.2
This worked without a single problem. I’ve downloaded the RubyGems 1.7.1
and installed that as well, basic test for me to see if the system
recognized the ruby executable from the command line.

However, when I call the command ‘gem update --system’ I receive the
following error:
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - H:/

Ok, seems ruby wants to look into my network drive for gem
installations. I don’t like this so I created the GEM_PATH and GEM_HOME
variables:

C:\Windows\System32>set GEM
GEM_HOME=C:\Ruby.gems
GEM_PATH=C:\Ruby\1.9.2\lib\ruby\gems\1.9.1\gems

Running the command again results in the same. Here is a complete look
of my ruby environment settings:

C:\Windows\System32>gem env
RubyGems Environment:

  • RUBYGEMS VERSION: 1.7.1
  • RUBY VERSION: 1.9.2 (2011-02-18 patchlevel 180) [i386-mingw32]
  • INSTALLATION DIRECTORY: C:/Ruby/.gems
  • RUBY EXECUTABLE: C:/Ruby/1.9.2/bin/ruby.exe
  • EXECUTABLE DIRECTORY: C:/Ruby/.gems/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86-mingw32
  • GEM PATHS:
    • C:/Ruby/.gems
    • C:/Ruby/1.9.2/lib/ruby/gems/1.9.1/gems
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

C:\Windows\System32>set home
HOMEDRIVE=H:
HOMEPATH=
HOMESHARE=\tenforce-ad\userdata\Arne.De.Herdt

Can anyone tell me what is actually wrong with my installation and what
can be done to get this working?

Found it…
need to the a HOME environment variable…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs