Gem install specific version

I know that I can do:

gem install --version ‘> 0.3.2’ packagename

but what if there is a “mswin” and a “ruby” version? Any way to get
it to pick the right one?

Mike B.

On 5/8/07, barjunk [email protected] wrote:

I know that I can do:

gem install --version ‘> 0.3.2’ packagename

but what if there is a “mswin” and a “ruby” version? Any way to get
it to pick the right one?

Not that I know of, but there’s been quite a bit of discussion of late
on the rubygems list on getting gem to recognize different platforms
and do away with the need to select mswin vs. ruby vs. new platforms
like jruby.

It seems to have the attention of the gems developers. I for one will
welcome this when they implement it.


Rick DeNatale

My blog on Ruby
http://talklikeaduck.denhaven2.com/

I second that. There is plenty of information about the system
available to software.

On May 8, 8:29 pm, barjunk [email protected] wrote:

I know that I can do:

gem install --version ‘> 0.3.2’ packagename

but what if there is a “mswin” and a “ruby” version? Any way to get
it to pick the right one?

Mike B.

yes, vial gem install. For example:

C:\Documents and Settings\Owner>gem install ruby-debug-base
Select which gem to install for your platform (i386-mswin32)

  1. ruby-debug-base 0.9.3 (ruby)
  2. ruby-debug-base 0.9.3 (mswin32)
  3. ruby-debug-base 0.9.2 (mswin32)
  4. ruby-debug-base 0.9.2 (ruby)
  5. Skip this gem
  6. Cancel installation

2

Have you tried? gem install --version ‘= 0.3.2 (mswin32)’ packagename

I normally use the first example …

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs