Gem install ruby-debug


#1

tinix@Creek:/home/tinix/test/grin# gem install ruby-debug
Building native extensions. This could take a while…
ERROR: Error installing ruby-debug:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb install ruby-debug
extconf.rb:1:in `require’: no such file to load – mkmf (LoadError)
from extconf.rb:1

Gem files will remain installed in /var/lib/gems/1.8/gems/linecache-0.43
for inspection.
Results logged to /var/lib/gems/1.8/gems/linecache-0.43/ext/gem_make.out
tinix@Creek:/home/tinix/test/grin#

what is the problem …???

Thanks Tinix./


#2

On Apr 7, 5:40 am, Daniel T. removed_email_address@domain.invalid
wrote:

for inspection.
Results logged to /var/lib/gems/1.8/gems/linecache-0.43/ext/gem_make.out
tinix@Creek:/home/tinix/test/grin#

what is the problem …???

That usually means that you don’t have the development headers for
ruby (often a separate package on most linux distributions, eg ruby-
dev or ruby-devel)

Fred


#3

Frederick C. wrote:

On Apr 7, 5:40�am, Daniel T. removed_email_address@domain.invalid
wrote:

for inspection.
Results logged to /var/lib/gems/1.8/gems/linecache-0.43/ext/gem_make.out
tinix@Creek:/home/tinix/test/grin#

what is the problem …???

That usually means that you don’t have the development headers for
ruby (often a separate package on most linux distributions, eg ruby-
dev or ruby-devel)

Fred

Thank Fred…!!! look this
the package is ruby1.8-dev then install

tinix@Creek:/#sudo gem install ruby-debug
Building native extensions. This could take a while…
Building native extensions. This could take a while…
Successfully installed linecache-0.43
Successfully installed ruby-debug-base-0.10.3
Successfully installed ruby-debug-0.10.3
3 gems installed
Installing ri documentation for linecache-0.43…
Installing ri documentation for ruby-debug-base-0.10.3…
Installing ri documentation for ruby-debug-0.10.3…
Installing RDoc documentation for linecache-0.43…
Installing RDoc documentation for ruby-debug-base-0.10.3…
Installing RDoc documentation for ruby-debug-0.10.3…
tinix@Creek:/#
ok !
Again thanks Fred…!!