Gem install rails

Hi All,

I installed ruby184-20 and rubygems-0.9.0 on my computer. When I tried
to run C:\ruby>gem install rails --include-dependencies, it showed the
following message:
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find actionpack (= 1.12.4) in the repository

Could any one help to solve the above problem?

Thank you in advance.

Daniel

Daniel wrote:

Hi All,

I installed ruby184-20 and rubygems-0.9.0 on my computer. When I tried
to run C:\ruby>gem install rails --include-dependencies, it showed the
following message:
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find actionpack (= 1.12.4) in the repository

Could any one help to solve the above problem?

Thank you in advance.

Daniel

Just got the same emssage using a fresh install of the oneclick
installer ruby (which includes gems). I checked rubyforge and there is
not 1.12.4 version available for actionpack . Also I tried to download
and install rails via a local gem install and got the same error about
needing 1.12.4.

Ben

Just an update. So far I have cleared the gem cache and resynced it and
verified I am using 1.8.4.20 with gems .90. This does nothing to correct
the problem but I thought I would put it out there so everyone could see
and maybe help figure this one out.

Darushin

Daniel wrote:

I installed ruby184-20 and rubygems-0.9.0 on my computer. When I tried
to run C:\ruby>gem install rails --include-dependencies, it showed the
following message:
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find actionpack (= 1.12.4) in the repository

I’ve just got the same problem myself. It looks like a 1.1.5 release of
Rails has been “half-released”. I noticed that rubyforge was down for a
while earlier today, so maybe it went down halfway through a new version
being uploaded?

Anyway, you can get going by asking for version 1.1.4 instead:

gem install --version=1.1.4 rails

Works for me!

paul.butcher->msgCount++

Same error. I tried afeter a couple of hours and now this error:

ERROR: While executing gem … (OpenURI::HTTPError)
404 Not Found

I hope is just a temporary failure. It’s almost clear that the problem
involves the gem’s broken indexes. I’m sure that the Gem Team is now
aware of the issue and they’ll address it shortly.

Thanks Paul - this was killing me!!!

c.

Paul B. wrote:

Anyway, you can get going by asking for version 1.1.4 instead:

gem install --version=1.1.4 rails

Sounds like a transient problem caused by recent updates [1.12.4 is
the version of ActionPack used by Rails 1.1.5]. Try again now, and
you should be OK, and get Rails 1.1.6 and ActionPack 1.12.5.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs