Gem install of rails fails - please help if you can

Can anyone tell me what’s wrong here please?
I can’t seem to find the same problem elsewhere.

I’ve pasted in path and version numbers in case it helps.

E:>gem -v
0.9.0

E:>ruby -v
ruby 1.8.4 (2006-04-14) [i386-mswin32]

E:>path
PATH=e:\ruby\bin;e:\perl\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32
Wbem;C:\Program Files\ATI Technologies\ATI.ACE;C:\Program Files\Common
Files\Adobe\AGL

E:>gem install rails --include dependencies
Successfully installed rails-1.1.4
Successfully installed activesupport-1.3.1
Successfully installed activerecord-1.14.3
Successfully installed actionpack-1.12.3
Successfully installed actionmailer-1.2.3
Successfully installed actionwebservice-1.1.4
Installing ri documentation for activesupport-1.3.1…
Installing ri documentation for activerecord-1.14.3…
Installing ri documentation for actionpack-1.12.3…
Installing ri documentation for actionmailer-1.2.3…
Installing ri documentation for actionwebservice-1.1.4…
Installing RDoc documentation for activesupport-1.3.1…
Installing RDoc documentation for activerecord-1.14.3…
Installing RDoc documentation for actionpack-1.12.3…
Installing RDoc documentation for actionmailer-1.2.3…
Installing RDoc documentation for actionwebservice-1.1.4…
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find dependencies (> 0) in the repository

Thanks

Pete

On Jul 26, 2006, at 5:45 AM, [email protected] wrote:

Successfully installed activesupport-1.3.1
Installing RDoc documentation for activerecord-1.14.3…
Installing RDoc documentation for actionpack-1.12.3…
Installing RDoc documentation for actionmailer-1.2.3…
Installing RDoc documentation for actionwebservice-1.1.4…
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find dependencies (> 0) in the repository

Thanks

Pete

I’m not sure why it’s throwing the error, but it looks like
everything got installed. Have you tried just running 'rails
’ to see if it works?
-Mat

Mat S. wrote:

ruby 1.8.4 (2006-04-14) [i386-mswin32]
Successfully installed rails-1.1.4
Installing RDoc documentation for activesupport-1.3.1…

I’m not sure why it’s throwing the error, but it looks like
everything got installed. Have you tried just running 'rails
’ to see if it works?
-Mat

Thanks Mat. I had tried that and it spat it out!

Anyway, 3 seconds ago I got it sorted.
I ran
e:\ruby>gem install rails --include-dependencies
Note the extra -

It all worked. Hooray!

Pete

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs