Gem Install bundler fails

Hi

I re-installed ruby 1.9.3 using rvm but now I am not able to install
bundler & get the following error.

Please help. TIA

Pradeep

discourse [master] :zap: rvm list

rvm rubies

=* ruby-1.9.3-p484 [ x86_64 ]

=> - current

=* - current && default

* - default

:cloud: discourse [master] :zap: gem install bundler
/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/yaml.rb:84:in
<top (required)>': It seems your ruby installation is missing psych (for YAML output). To eliminate this warning, please install libyaml and reinstall your ruby. ERROR: Loading command: install (LoadError) dlopen(/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib Referenced from: /Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle Reason: image not found - /Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle ERROR: While executing gem ... (NoMethodError) undefined methodinvoke_with_build_args’ for nil:NilClass
:cloud: discourse [master] :zap:

On 19 December 2013 08:38, Pradeep S. [email protected] wrote:

:cloud: discourse [master] :zap: gem install bundler
/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/yaml.rb:84:in
`<top (required)>’:
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your
ruby.

What happened when you followed that advise?

Colin

On 19 December 2013 11:57, Pradeep S. [email protected] wrote:

What happened when you followed that advise?

Colin

It keeps giving the same error even after installing libyaml &
reinstalling rubies. (not sure, if it is installing libyaml correctly)

Googling for the error message suggests that you may need libyaml-dev
sudo apt-get install libyaml-dev
That would be for Ubuntu, but I suspect that is not the case. Google
will probably help.

Colin

Looks like problems with Homebrew, did you tried updating rvm and
homebrew
before trying again? if nothing works open a ticket here =>
https://github.com/wayneeseguin/rvm/issues

Colin L. wrote in post #1131073:

On 19 December 2013 08:38, Pradeep S. [email protected] wrote:

:cloud: discourse [master] :zap: gem install bundler
/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/yaml.rb:84:in
`<top (required)>’:
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your
ruby.

What happened when you followed that advise?

Colin

It keeps giving the same error even after installing libyaml &
reinstalling rubies. (not sure, if it is installing libyaml correctly)

Output

rvm reinstall all
Are you SURE you wish to ‘reinstall’ all rubies?
(anything other than ‘yes’ will cancel) > yes
Removing /Users/psethi/.rvm/src/ruby-1.9.3-p484 - please wait
Removing /Users/psethi/.rvm/rubies/ruby-1.9.3-p484 - please wait
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.7/x86_64/ruby-1.9.3-p484.
Continuing with compilation. Please read ‘rvm help mount’ to get more
information on binary rubies.
Checking requirements for osx.
Certificates in ‘/usr/local/etc/openssl/cert.pem’ already are up to
date.
Requirements installation successful.
Installing Ruby from source to:
/Users/psethi/.rvm/rubies/ruby-1.9.3-p484, this may take a while
depending on your cpu(s)…
ruby-1.9.3-p484 - #downloading ruby-1.9.3-p484, this may take a while
depending on your connection…
ruby-1.9.3-p484 - #extracting ruby-1.9.3-p484 to
/Users/psethi/.rvm/src/ruby-1.9.3-p484 - please wait
ruby-1.9.3-p484 - #configuring - please wait
ruby-1.9.3-p484 - #post-configuration - please wait
ruby-1.9.3-p484 - #compiling - please wait
ruby-1.9.3-p484 - #installing - please wait
Retrieving rubygems-2.1.11
Extracting rubygems-2.1.11 … - please wait
Removing old Rubygems files…
$LANG was empty, setting up LANG=en_US, if it fails again try setting
LANG to something sane and try again.
Installing rubygems-2.1.11 for ruby-1.9.3-p484 - please wait
Error running ‘env
GEM_PATH=/Users/psethi/.rvm/gems/ruby-1.9.3-p484:/Users/psethi/.rvm/gems/[email protected]:/Users/psethi/.rvm/gems/ruby-1.9.3-p484:/Users/psethi/.rvm/gems/[email protected]
GEM_HOME=/Users/psethi/.rvm/gems/ruby-1.9.3-p484
/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/bin/ruby -d
/Users/psethi/.rvm/src/rubygems-2.1.11/setup.rb’,
showing last 15 lines of
/Users/psethi/.rvm/log/1387453371_ruby-1.9.3-p484/rubygems.install.log
from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems.rb:208:in
finish_resolve' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/rdoc.rb:14:in<top (required)>’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/core_ext/kernel_require.rb:55:in
require' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/core_ext/kernel_require.rb:55:inrequire’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/uninstaller.rb:10:in
<top (required)>' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/core_ext/kernel_require.rb:55:inrequire’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/core_ext/kernel_require.rb:55:in
require' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/commands/setup_command.rb:474:inuninstall_old_gemcutter’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/commands/setup_command.rb:146:in
execute' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/command.rb:305:ininvoke_with_build_args’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/command_manager.rb:167:in
process_args' from /Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/command_manager.rb:137:inrun’
from
/Users/psethi/.rvm/src/rubygems-2.1.11/lib/rubygems/gem_runner.rb:54:in
run' from setup.rb:45:in
RubyGems 2.1.11 installed
Installation of rubygems did not complete successfully.

  • please wait
    ruby-1.9.3-p484 - #gemset created
    /Users/psethi/.rvm/gems/[email protected]
    ruby-1.9.3-p484 - #importing gemset
    /Users/psethi/.rvm/gemsets/global.gems - please wait
    ruby-1.9.3-p484 - #generating global wrappers - please wait
    ERROR: While executing gem … (Gem::CommandLineError)
    Unknown command wrappers
    ruby-1.9.3-p484 - #gemset created
    /Users/psethi/.rvm/gems/ruby-1.9.3-p484
    ruby-1.9.3-p484 - #generating default wrappers - please wait
    ERROR: While executing gem … (Gem::CommandLineError)
    Unknown command wrappers
    ruby-1.9.3-p484 - #adjusting #shebangs for (gem irb erb ri rdoc testrb
    rake).
    Install of ruby-1.9.3-p484 - #complete
    Ruby was built without documentation, to build it run: rvm docs
    generate-ri
    Making gemset ruby-1.9.3-p484 pristine. - please wait
    :cloud: yaml-0.1.4 gem install bundler
    ERROR: Loading command: install (LoadError)
    dlopen(/Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle,
    9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
    Referenced from:
    /Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle
    Reason: image not found -
    /Users/psethi/.rvm/rubies/ruby-1.9.3-p484/lib/ruby/1.9.1/x86_64-darwin11.4.2/openssl.bundle
    ERROR: While executing gem … (NoMethodError)
    undefined method `invoke_with_build_args’ for nil:NilClass

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs