Gem dependency tool

Here a little script for detection gem & version used for some
requirements :
https://gist.github.com/raubarede/5214546

example :

ruby dependency.rb gtk3
require gtk3
pkg-config 1.1.4 => test-unit:>= 0 / test-unit-notify:>= 0 /
glib2 1.2.3 => pkg-config:>= 0 / test-unit:>= 2
gio2 1.2.3 => glib2:>= 1.2.3
atk 1.2.3 => glib2:>= 1.2.3
cairo 1.12.4 => pkg-config:>= 0 / bundler:>= 0 /
test-unit-notify:>= 0 / rake-compiler:>= 0 / packnga:>= 0
pango 1.2.3 => cairo:>= 1.10.0 / glib2:>= 1.2.3
gdk_pixbuf2 1.2.3 => glib2:>= 1.2.3
gdk3 1.2.3 => atk:>= 1.2.3 / pango:>= 1.2.3 /
gdk_pixbuf2:>= 1.2.3
gtk3 1.2.3 => glib2:>= 1.2.3 / gio2:>= 1.2.3 / atk:>=
1.2.3 / pango:>= 1.2.3 / gdk_pixbuf2:>= 1.2.3 / gdk3:>= 1.2.3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs