Gem 0.9.5, gempath, .gemrc, require on OS X, Works, but my goodness, what a mess

Hi,

I’m running OS X 10.5.1, have been running Ruby for years, Rails for
years… this is not a new install.

I’ve got something like 109 gems installed.

I upgraded gems to 0.9.5 this morning.

I tried to install Rails 2.0.1 this morning immediately after
upgrading gems, that’s six gems.

Okay, it worked, but it decided to install them someplace other that
where the other 104 gems were installed without a hitch by gems 0.9.4.

After a bunch of increasingly random flailing I managed to get the
install to put the gems into the same place as it used to. I did this
by setting up both a .gemrc file and changing the GEM_PATH that I
needed with 0.9.4

So I tried to run rails. Nope. Can’t find the daemons gem. Ran irb,
tried to require daemons. Nope. Tried ‘gems which daemons’. Identified
the gem just fine.

So I started, more seemingly randomly flailing (I hate that), to poke
at the gems environment.

I want the gems to be located in /Library/Ruby/Gems/gems/

So here is how it ends up:

In my .bashrc file:

export GEM_PATH="/Library/Ruby/Gems/:/Library/Ruby/Gems/gems/" #BOTH
paths need to be there

My .gemrc file:

gem: --install-dir /Library/Ruby/Gems/
gempath:

  • /Library/Ruby/Gems/

Note that in gem 0.9.4 no .gemrc and only the following .bashrc line
was needed:

export GEM_PATH="/Library/Ruby/Gems/"

Anyway, this seems to work, but it is really just a bit too convoluted
for words.

Am I the only person having this problem?

Thanks,
Bob


Bob H. – tumblelog at
http://www.recursive.ca/so/
Recursive Design Inc. – weblog at
http://www.recursive.ca/hutch
http://www.recursive.ca/ – works on
http://www.raconteur.info/cms-for-static-content/home/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs