Gateway slow

Hi there,

apparently the direction news -> mailing is broken (or extremely
slow). I don’t see a posting I did ~5 hours ago. Anybody with
similar experiences?

Cheers

robert

On Mar 19, 2010, at 7:20 AM, Robert K. wrote:

apparently the direction news -> mailing is broken (or extremely
slow). I don’t see a posting I did ~5 hours ago. Anybody with
similar experiences?

Can you point me at the post you are referring to on the newsgroup side
so I can look it up and see what happened to it? Thanks.

James Edward G. II

2010/3/19 James Edward G. II [email protected]:

On Mar 19, 2010, at 7:20 AM, Robert K. wrote:

apparently the direction news -> mailing is broken (or extremely
slow). I don’t see a posting I did ~5 hours ago. Anybody with
similar experiences?

Can you point me at the post you are referring to on the newsgroup side so I can look it up and see what happened to it? Thanks.

http://groups.google.de/group/comp.lang.ruby/browse_frm/thread/1030ad4858886ddf/af74b26045f69573

My first posting - I don’t see it on the mailing list.

Thanks for offering support!

Kind regards

robert

On Mar 19, 6:20 am, Robert K. [email protected] wrote:

apparently the direction news -> mailing is broken (or extremely
slow). I don’t see a posting I did ~5 hours ago. Anybody with
similar experiences?

Here’s a test posted to Google groups at 07:26 MST.

On Mar 19, 2010, at 10:29 AM, Robert K. wrote:

My first posting - I don’t see it on the mailing list.

Fred, we hare having trouble getting Usenet postings from your server.
The issue comes when I try to skip forward to a recent article, using
this code in the gateway:

switch to the last message we sent (or the first real message before

that)
begin
Timeout.timeout(30) do
nntp.stat(last_id_sent)
end
rescue Timeout::Error
log.error “The NNTP message shift timed out.”
exit
rescue
if $!.message.include?(“Bad article number”) and last_id_sent.nonzero?
last_id_sent -= 1
retry
else
log.fatal “Unable to switch to the last message: #{$!.message}”
exit -1
end
end

The server appears to be denying all of my stat() calls as last_id_sent
just keeps counting down:

ruby /var/ruby_talk_gateway/bin/news_to_mail.rb

/var/log/gateway_news_to_mail.log
263164
263163
263162
263161
263160
263159
263158
263157
263156

Any thoughts?

James Edward G. II

Le 19 mars 2010 à 17:00, James Edward G. II a écrit :

Hi.

Can you point me at the post you are referring to on the newsgroup side so I
can look it up and see what happened to it? Thanks.

http://groups.google.de/group/comp.lang.ruby/browse_frm/thread/1030ad4858886ddf/af74b26045f69573

My first posting - I don’t see it on the mailing list.

Fred, we hare having trouble getting Usenet postings from your server.
The issue comes when I try to skip forward to a recent article, using
this code in the gateway:
/…/
263158
263157
263156
?

Any thoughts?

I’m not sure of what this code is supposed to do. Well, of why it does
that, to be precise - are you trying to find the last gated article to
retrieve an ID ?

In this case, the reason it’s looping is quite simply that you are
trying to get articles below the first article in the group (returned by
the “group” command).

| 11:00 [email protected]:~% telnet localhost 119
| /…/
| group comp.lang.ruby
| 211 204 263180 263385 comp.lang.ruby
^^^^^^ ^^^^^^
lomark himark

| stat 263180
| 223 263180 [email protected] status
| stat 263179
| 423 Bad article number

This is due to yet another hardware problem with the box recently (the
disk controller died). It seems the overview database (the database of
important header fields) has been corrupted for this group, leading to a
very low number of articles (205) while I have a few thousands on disk.

I have just launched a rebuild of the databases, it should recover all
the articles… but it’s a bit slow on that machine.

The good news is that I have found a replacement server. I’ll try to
put it in production in a few weeks.

CYA,

Fred

On Mar 20, 5:57 am, “F. Senault” [email protected] wrote:

| 211 4437 259122 263387 comp.lang.ruby

Much better !

Testing a post from the Usenet side.

James Edward G. II

Le 20 mars 2010 à 11:28, F. Senault a écrit :

| 11:00 [email protected]:~% telnet localhost 119
| /…/
| group comp.lang.ruby
| 211 204 263180 263385 comp.lang.ruby
^^^^^^ ^^^^^^
lomark himark
| group comp.lang.ruby
| 211 4437 259122 263387 comp.lang.ruby

Much better !

Fred

On 03/20/2010 09:52 PM, James Edward G. II wrote:

| group comp.lang.ruby
| 211 4437 259122 263387 comp.lang.ruby

Much better !

Yep, it looks like we are back in business. Thanks!

Thanks from me as well!

Kind regards

robert

On Mar 20, 2010, at 7:42 AM, F. Senault wrote:

Much better !

Yep, it looks like we are back in business. Thanks!

James Edward G. II

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs