Fxri incomplete


#1

I like fxri but why is it that some very essential libraries, e.g. the
socket library (with classes TCPSocket, TCPServer, etc.), are not
included?

It is sad that fxri is so crippled. I have to grab the PickAxe2 book
all the time.


#2

Hello:

Fxri is based on ri. Ri by default only contains documentation on the
core library. TCPSocket and the like are included in the standard
library, not the core library. I’m not sure how to have ri see the
standard library. However, I think that is the main issue.

-Ted

PS: This distinction can be seen at http://www.ruby-doc.org


#3

I’ve just found out that the online “Ruby Standard Library
Documentation” at http://www.ruby-doc.org/stdlib/ includes the socket
library, so I don’t have to refer to PickAxe2 if I didn’t want to (and
if I’m connected).


#4

X-Man wrote:

I’ve just found out that the online “Ruby Standard Library
Documentation” at http://www.ruby-doc.org/stdlib/ includes the socket
library, so I don’t have to refer to PickAxe2 if I didn’t want to (and
if I’m connected).

That page should also have a link for downloading a tarball or zip file
of the std-lib rdocs.

You can read them 24-hours a day!

James

http://www.ruby-doc.org - Ruby Help & Documentation
http://www.artima.com/rubycs/ - Ruby Code & Style: Writers wanted
http://www.rubystuff.com - The Ruby Store for Ruby Stuff
http://www.jamesbritt.com - Playing with Better Toys
http://www.30secondrule.com - Building Better Tools