Fxri - gems - fxruby


#1

I am using Ruby 1.8.2 (2004-12-25) [i386-mswin32] on Windows XP.

fxri working perfectly before installing Fxruby. Then, after installing,
stops working:

Am I missing something? The output follows.

Thanks a lot.


E:\Ruby>gem install fxruby-1.4.2-mswin32.gem

E:\Ruby>“e:\Ruby\bin\ruby.exe” “e:\Ruby\bin\gem” install
fxruby-1.4.2-mswin32.ge
m
Attempting local installation of ‘fxruby-1.4.2-mswin32.gem’
Successfully installed fxruby, version 1.4.2
Installing RDoc documentation for fxruby-1.4.2-mswin32…

E:\Ruby>E:\Ruby\bin\fxri.cmd

E:\Ruby>“e:\Ruby\bin\ruby.exe” “e:\Ruby\bin\fxri”
e:/Ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in activate': can't activate fxr uby (= 1.2.6), already activated fxruby-1.4.2-mswin32] (Gem::Exception) from e:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:inre
quire’
from e:/Ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
from e:/Ruby/bin/fxri:19:in `load’
from e:/Ruby/bin/fxri:19


#2

Kilivor K. schrieb:

I am using Ruby 1.8.2 (2004-12-25) [i386-mswin32] on Windows XP.

fxri working perfectly before installing Fxruby. Then, after
installing, stops working:

E:\Ruby>gem install fxruby-1.4.2-mswin32.gem

I had this problem in the past too. The installed fxri needs fxruby
1.2.x. You have two options:

  1. Remove fxruby 1.4.x and (re-)install fxruby 1.2.6. fxri does not work
    if both versions are installed!

  2. Manually patch the gemspec file for fxri. Edit
    \lib\ruby\gems\1.8\specifications\fxri-0.3.2.gemspec

with a text editor. Near the end change the line

s.add_dependency(%q<fxruby>, [">= 1.2.0"])

to

s.add_dependency(%q<fxruby>, [">= 1.2.0", "< 1.3"])

After this, fxri works with the previously installed fxruby 1.2.x and
ignores newer versions.

Be aware that the FreeRide which is included in the One-click-installer
does depend on fxruby 1.2.x too. For freeride to work again you would
have to change several files in
\freeride\freebase\lib\freebase. I haven’t done or
checked this as I don’t use freeride.

Holger


#3

On 1/12/06, Holger A. removed_email_address@domain.invalid wrote:

I had this problem in the past too. The installed fxri needs fxruby
1.2.x. You have two options:

FWIW, I just sent an e-mail to Martin Ankerl (the author of fxri) to
see what’s up with this. This is a known problem that a lot of people
have run into, and I don’t know if it’s going to be fixed or not…


#4

Holger A. wrote:

After this, fxri works with the previously installed fxruby 1.2.x and
ignores newer versions.

Be aware that the FreeRide which is included in the One-click-installer
does depend on fxruby 1.2.x too. For freeride to work again you would
have to change several files in
\freeride\freebase\lib\freebase. I haven’t done or
checked this as I don’t use freeride.

Thanks Holger! fxri working again! About FreeRide I neither use it, so
for now it is no prob (using Eclipse).