Fwd: HOW TO USE SSL IN SAVON

HI All,

I want to consume the SOAP apis using SSL in the SAVON gem, but I am
facing
the below error while trying to access the soap services.

client = Savon.client(wsdl: “https://xxx?WSDL”)
client.operations

HTTPI GET request to xxxxx (curb)
HTTPI::SSLError: Curl::Err::SSLPeerCertificateError

In the Savon site http://savonrb.com/version2.html#globals-ssl I found
that options to pass the SSL certificate file, but I didin’t understand
it,
since why do we need to have the ssl certificate to consume the API?
Also
let me know the way to consume the SOAP service with SSL.

regards,
Loganathan
Mob: +91 7760780741 | +91 9944414388
Skype: loganathan.sellappa
ViewMe http://vizualize.me/loganathan

On Tuesday, January 8, 2013 8:40:56 AM UTC, Loganathan Sellappa wrote:

HTTPI::SSLError: Curl::Err::SSLPeerCertificateError

In the Savon site http://savonrb.com/version2.html#globals-ssl I found
that options to pass the SSL certificate file, but I didin’t understand it,
since why do we need to have the ssl certificate to consume the API? Also
let me know the way to consume the SOAP service with SSL.

Well some webservices do require that clients authenticate themselves
using
a certificate. Does the webservice in question have that requirement?

Fred

On Tuesday, 8 January 2013 03:40:56 UTC-5, Loganathan Sellappa wrote:

HTTPI::SSLError: Curl::Err::SSLPeerCertificateError

In the Savon site http://savonrb.com/version2.html#globals-ssl I found
that options to pass the SSL certificate file, but I didin’t understand it,
since why do we need to have the ssl certificate to consume the API? Also
let me know the way to consume the SOAP service with SSL.

The specific error you’re getting is HTTPI complaining that the SSL cert
of
the remote server can’t be verified. You’ll need to include (at a
minimum)
the certificate of the CA who issued the remote server’s key
in ssl_ca_cert_file (also in the documentation you linked to).

–Matt J.

Nope :frowning: , currently consuming the api without SSL.

regards,
Loganathan
Mob: +91 7760780741 | +91 9944414388
Skype: loganathan.sellappa
ViewMe http://vizualize.me/loganathan

On Thu, Jan 24, 2013 at 9:32 AM, Almir M. [email protected]
wrote:

Do you find a solution? I’m having the same issue, the error only happen
for a specific domain.

http.auth.ssl.verify_mode = :none

I’m trying that but dont’s work. I’m still having the error message.

SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello
A

Hi Loganathan,

Do you find a solution? I’m having the same issue, the error only happen
for a specific domain.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs