Fwd: Fastcgi returning 404 and nginx overwriting it to 200

Hi all,

My version is 0.7.67-3 coming from Debian Squeeze.
I have tried with squeeze-backports which is version 1.2.1-2.2~bpo60+2
but
I got the same results.

I have reduced this to the smallest config for fastcgi available and it
still does the same.
There are no intercept_redirects directives or error_pages neither.

I have tried enabling the debug log and I see messages like “upstream
split
a header line in FastCGI records”
Strace-ing it later I see the first few lines sent, like the status one
are
splited in 2 recvfroms, but I assume this shouldn’t be a problem.
I see clearly that nginx is receiving a 404 but sending back to the
client
the output intact but a 200 ok.

Am I doing/assuming something wrong in here or could this be a bug?

Hi,

I managed to fix it by changing uwsgi as fcgi runner from version 1.4.6
to
version 1.9.17.1, this fixed the issues, not sure what side was wrong.


Arkaitz

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs