FW: USB problem with USRP

Hi all

Resolved this problem - it appears to have been a library conflict. I’m
not sure which one, but having re-installed some of the libraries in
different locations and making sure the build uses the correct libs it
now works OK.

Rich


From: Richard M.
Sent: 20 November 2006 10:18
To: ‘[email protected]
Subject: USB problem with USRP

Hi

I’m trying to get the USRP to work, using the test_usrp_standard_tx
program, but am not having any luck.

On execution, the flashing LED on the USRP goes out, and there is a
delay of about 3 seconds on the PC, then the following message repeated:

Usb_control_msg failed: error sending control message: Connection timed
out

Followed by:

Usrp: failed to load fpga bitstream
/usr/share/usrp/rev4/std_2rxhb_2tx.rbf.

In USBView I see the device as a 480Mbps USB2 device with VID FFFE, PID
0002 and Rev 0004 (both before and after running the above app). If I
manually try using fxload after a power cycle of the USRP board (e.g.
fxload -t fx2 -D /dev/bus/usb/03/019 -I ./std.ihx) then the flashing LED
goes out, but I get no other indication that things have worked.

I’m running this on a Fujitsu Lifebook, running Mandriva 7.

I’ve tried searching the gnuradio docs but can’t find anything that
mentiones the “Connection timed out” error above.

Any help would be greatly appreciated!

Cheers

Rich

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs