Full URL in http GET

Hello,

I’m trying to get nginx to work with a squid back end. In our
environment, we require the full URL in the GET line, which is how squid
can distinguish between an http and https request. The role of nginx is
to decode the ssl session and pass on the request in plain http to
squid.

For example, if we request this URL against nginx:

https://asdf/test

The request will come in from the client looking like this:

GET /test HTTP/1.1
Host: asdf

What I’d like nginx to do, is for nginx to connect to the back end squid
server like this:

GET https://asdf/test HTTP/1.0
Host: asdf

Instead of what it is currently doing, which is this:

GET /test HTTP/1.0
Host: asdf

Is there a way to do this with nginx?

Thanks,
-Jason

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,7007,7007#msg-7007

On Tue, Sep 15, 2009 at 00:00, eggnet [email protected] wrote:

Hello,

I’m trying to get nginx to work with a squid back end. Â In our environment, we require the full URL in the GET line, which is how squid can distinguish between an http and https request. Â The role of nginx is to decode the ssl session and pass on the request in plain http to squid.

Doesn’t squit handle http headers? Try
http://wiki.nginx.org/NginxHttpUpstreamModule or some other module on
the wiki, or maybe the $uri variable? Not sute.

Unfortunately, we are trying to connect to Squid in forward proxy mode.
I found someone else trying to do the same thing:

http://marc.info/?l=nginx&m=123075443918107&w=2

But no luck there.

In forward proxy mode, it is standard to pass the full URL in the GET
line, and not just the part after the host, but I don’t see any option
in nginx to do this.

vesperto Wrote:

Doesn’t squit handle http headers? Try
http://wiki.nginx.org/NginxHttpUpstreamModule or
some other module on
the wiki, or maybe the $uri variable? Not sute.


() ascii-rubanda kampajno - kontraÅ­ html-a
retpoŝto
/\ ascii ribbon campaign - against html e-mail

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,7007,7120#msg-7120

Actually it looks like the link I posted showed someone trying to
connect to a forward proxy like I am, but the method is a little
different. My original post is the most descriptive.

eggnet Wrote:

after the host, but I don’t see any option in
nginx to do this.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,7007,7122#msg-7122

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs