Frustrated with ruby install


but when I do
type rvm | head -1

it says:
rvm is /home/user/.rvm/bin/rvm

but expected is:
rvm is a function,

So if,

I do:
rvm use --default 1.8.7

RVM is not a function, selecting rubies with ‘rvm use …’ will not

You need to change your terminal emulator preferences to allow login
Sometimes it is required to use /bin/bash --login as the command.
Please visit RVM: Ruby Version Manager - Using gnome-terminal with RVM for a example.

My goal is to install ruby 1.8.7 on ubuntu, actually I crashed previous
install so I uninstalled and trying to reinstall,-- am fighting very
hard to do it.