Fresh install (error): comparison of String with 60 failed

Rack 1.2
Rails 3
Ruby 1.9.2

Perhaps you guys and gals can help me figure out how to fix this error:

Processing SiteController#show_page (for # at 2010-11-03 14:32:33) [GET]
Parameters: {“controller”=>“site”, “action”=>“show_page”, “url”=>"/"}

ArgumentError (comparison of String with 60 failed):
radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:421:in <' radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:421:inblock
in perform_parse’
radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:417:in loop' radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:417:inperform_parse’
radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:22:in
operate' radiant (0.9.1) vendor/radius/lib/radius/parser.rb:37:intokenize’
radiant (0.9.1) vendor/radius/lib/radius/parser.rb:29:in parse' radiant (0.9.1) app/models/page.rb:302:inparse’
radiant (0.9.1) app/models/page.rb:307:in parse_object' radiant (0.9.1) app/models/page.rb:127:inrender’
radiant (0.9.1) app/models/page.rb:117:in process' radiant (0.9.1) app/controllers/site_controller.rb:62:inprocess_page’
radiant (0.9.1) app/controllers/site_controller.rb:21:in show_page' <internal:prelude>:10:insynchronize’
passenger (3.0.0) lib/phusion_passenger/rack/request_handler.rb:96:in
process_request' passenger (3.0.0) lib/phusion_passenger/abstract_request_handler.rb:513:inaccept_and_process_next_request’
passenger (3.0.0)
lib/phusion_passenger/abstract_request_handler.rb:274:in main_loop' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:321:instart_request_handler’
passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:275:in block in handle_spawn_application' passenger (3.0.0) lib/phusion_passenger/utils.rb:479:insafe_fork’
passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:270:in
handle_spawn_application' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:inserver_main_loop’
passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:206:in
start_synchronously' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:180:instart’
passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:149:in
start' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:219:inblock
(2 levels) in spawn_rails_application’
passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:132:in
lookup_or_add' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:214:inblock
in spawn_rails_application’
passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:82:in block in synchronize' <internal:prelude>:10:insynchronize’
passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:79:in synchronize' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:213:inspawn_rails_application’
passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:132:in
spawn_application' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:275:inhandle_spawn_application’
passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:in
server_main_loop' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:206:instart_synchronously’
passenger (3.0.0) helper-scripts/passenger-spawn-server:99:in `’

On Wed, Nov 3, 2010 at 2:51 PM, Jordon B. [email protected]
wrote:

Rack 1.2
Rails 3
Ruby 1.9.2

Perhaps you guys and gals can help me figure out how to fix this error:

try:

Rack 1.1.0
Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
being loaded; i.e. you don’t need to install Rails at all)
Ruby 1.8.7

Radiant does not run on any of the software you mentioned.

On Nov 3, 2010, at 4:04 PM, john muhl wrote:

Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
being loaded; i.e. you don’t need to install Rails at all)
Ruby 1.8.7

Radiant does not run on any of the software you mentioned.

YET

On 11/03/2010 03:14 PM, Jim G. wrote:

try:

Rack 1.1.0
Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
being loaded; i.e. you don’t need to install Rails at all)
Ruby 1.8.7

Radiant does not run on any of the software you mentioned.

YET

Will do, thanks for pointing that out.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs