Freezing Rails 2.3.4 to application

Hi Everyone

I am trying to update my Rails 2.1.2 to Rails 2.3.4.

I have upgraded to Rails 2.3.4 and freezed the Rails 2.3.4 to my
application. But when am trying to run the server , am getting this
error

config.gem: Unpacked gem ClothRed in vendor/gems has no specification
file. Run
‘rake gems:refresh_specs’ to fix this.
config.gem: Unpacked gem ClothRed in vendor/gems not in a versioned
directory. G
iving up.
config.gem: Unpacked gem mime-types-1.15 in vendor/gems has no
specification fil
e. Run ‘rake gems:refresh_specs’ to fix this.
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/lib/active_supp
ort/core_ext/module/aliasing.rb:33:in alias_method': undefined methodpick_tem
plate’ for class ActionView::TemplateFinder' (NameError) from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/core_ext/module/aliasing.rb:33:inalias_method_chain’
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/plugins/active_scaffol
d/lib/extensions/generic_view_paths.rb:35
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in ge m_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inre
quire’
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li
b/active_support/dependencies.rb:156:in require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:521:innew_constants_in’
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li
b/active_support/dependencies.rb:156:in require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/plugins/active_scaffol d/environment.rb:63 ... 25 levels... from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/railties/lib/com mands/server.rb:84 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
quire’
from script/server:3

Am i missing something , do i have to do something else also.

Please Advice !
Thanks in Advance.

Neetal

The first couple warnings are related to the 2.1 era gem freezer,
which didn’t unpack gemspecs. The rake task listed in the error should
fix that.

The other error appears to be from activescaffold trying to override
part of ActionView; I’d guess that you’ll need to upgrade
activescaffold.

–Matt J.

On Sep 10, 7:26 am, Neetal S. [email protected]

Thanks much Matt…

That worked for me , now am running in to some different issue.

When i tried to run the server it says

===========================================================================================
c:/ruby/lib/ruby/gems/1.8/gems/acts_as_ferret-0.4.4/lib/acts_as_ferret.rb:267:
w
arning: parenthesize argument(s) for future version
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_re quire': no such file to load -- ferret_ext (MissingSourceFile) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inre
quire’
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li
b/active_support/dependencies.rb:156:in require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:521:innew_constants_in’
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li
b/active_support/dependencies.rb:156:in require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/gems/ferret-0.11.6/lib /ferret.rb:25 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:inge
m_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in re quire' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:156:inrequire’
… 14 levels…
from
C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/railties/lib/com
mands/server.rb:84
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in ge m_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inre
quire’
from script/server:3

===================================================================================

But i do have
1> ferret (0.11.5) gem installed and acts_as_ferret (0.4.4, 0.3.1) gem
installed.
2> I have already added these lines to environment.rb
i>require ‘acts_as_ferret’
ii>config.gem ‘ferret’

but still facing the problem, no clue which version of ferret i should
install.

Could you please suggest something.

Thanks and Advance !!

Neetal

The error is looking for ferret_ext, which is actually a DLL created
by the gem installer when the ferret gem is installed. My guess is
that you’re missing the compiler toolchain needed to build it on
Windows; you may want to find a binary version of the gem. This thread
may be helpful:

http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/02def3b3133bb0ab/e702ed8307fc1837?lnk=raot

–Matt J.

On Sep 11, 2:55 am, Neetal S. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs