Fragment cache hit is super slow every two times

Hi,

I have a piece of html that I fragment cache. For a very strange reason
every two times I request the page, rendering the fragment cache takes a
lot of time.

Example:

  1. I request index page, rendering takes 300ms
  2. I request again index page, rendering takes 1300ms
  3. I request again index page, rendering takes 300ms
  4. and so on

Where could that come from???

Fernando P. wrote:

Hi,

I have a piece of html that I fragment cache. For a very strange reason
every two times I request the page, rendering the fragment cache takes a
lot of time.

Example:

  1. I request index page, rendering takes 300ms
  2. I request again index page, rendering takes 1300ms
  3. I request again index page, rendering takes 300ms
  4. and so on

Where could that come from???

I try to do some profiling with script/performance/request, but it seems
broken, because when it has finished making requests, it never renders
the results. In Rails 2.1.1 it worked fine though.

Has anyone encountered this problem?

I try to do some profiling with script/performance/request, but it seems
broken, because when it has finished making requests, it never renders
the results. In Rails 2.1.1 it worked fine though.

Has anyone encountered this problem?

I had forgotten to use production environment for the profiling, now it
renders the results.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs