foxGUIb - status?

This project - “a GUI creator and code generator for FXRuby” - looks
promising, but…

Is it dead?

It sure is for me, since I can’t get the install to launch. This is
supposed to be a fully self-contained package (with it’s own ruby). It
comes with two directories -

  • libGUIb - The instructions say to install this first - has ruby, etc.
    No way of offered to skip this step, so I didn’t:

$ sudo ruby install.rb
[sudo] password for tom:
parsearg_config
install.rb: entering config phase…
—> lib
<— lib
install.rb: config done.
parsearg_setup
install.rb: entering setup phase…
—> lib
<— lib
install.rb: setup done.
parsearg_install
parsearg_install!!! ARGV:
install.rb: entering install phase…
—> lib
mkdir -p /usr/local/lib/site_ruby/1.8/
install libGUIb14.rb /usr/local/lib/site_ruby/1.8/
install libGUIb16.rb /usr/local/lib/site_ruby/1.8/
<— lib
install.rb: install done.

  • foxGUIb - regarding this directory, the instructions say simply
    “install foxGUIb: you can copy foxGUIb’s directory where ever you want
    to.” I read everything I could find, to shed light on what this second
    “install” is supposed to be. Couldn’t find a clarification. In the root
    of this dir there is one, only, *.rb fle - foxGUIb.rb, so…

$ ruby foxGUIb.rb
please install libGUIb!!
no such file to load – fox16

Very confusing. I just installed libGUIb.

Any and all information / help anyone can provide would be appreciated.

Thanks,

t.

Tom C., MS MA, LMHC
Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< [email protected] >> (email)
<< TomCloyd.com >> (website & psychotherapy weblog)
<< sleightmind.wordpress.com >> (mental health issues weblog)
<< directpathdesign.com >> (web site design & consultation)

On Sat, Apr 12, 2008 at 11:25 AM, Tom C. [email protected]
wrote:

This project - “a GUI creator and code generator for FXRuby” - looks
promising, but…

Is it dead?

I would not say so. There has just not been a good reason to release
another
version.
If you like to send in patches I will create a new release.

install.rb: entering config phase…
install.rb: entering install phase…
supposed to be. Couldn’t find a clarification. In the root of this dir there
is one, only, *.rb fle - foxGUIb.rb, so…

$ ruby foxGUIb.rb
please install libGUIb!!
no such file to load – fox16

Very confusing. I just installed libGUIb.

it seems that fxruby 1.6 is probably not installed.
– henon

Meinrad R. wrote:

It sure is for me, since I can’t get the install to launch. This is
<— lib
mkdir -p /usr/local/lib/site_ruby/1.8/

Henon,

Thank you. I’m happy to hear that (as I suspected!) the problem is my
ignorance. I can fix that - I’m really not capable of offering patches,
sadly. However, that there’s been no need to offer a new version, in two
years, seems to me to be a testament to the quality and utility of the
programming already done. Really good news!

As for fxruby…yes, that’s not installed. I didn’t read anywhere that
it needed to be. I know that these things are obvious to other people,
or to some other people, but my limited time to work with ruby means my
depth of knowledge is always thin. A large handicap, at times. Often, in
fact. Because of this, I’m very grateful for this list.

So…I will work on installing fxruby (which has been a problem for me),
then return to foxGUIb. Thanks so much for your reply.

Tom

Tom C., MS MA, LMHC
Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< [email protected] >> (email)
<< TomCloyd.com >> (website & psychotherapy weblog)
<< sleightmind.wordpress.com >> (mental health issues weblog)
<< directpathdesign.com >> (web site design & consultation)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs