foxGUIb & ruby 1.8.5 spewing hundreds of errors at launch ti

Greetings all,

I decided to step up to Ruby 1.8.5 today. After installing 1.8.5, I
completely uninstalled and reinstalled fox (1.6.16), fxscintilla
(1.71), FXRuby (1.6.3), and foxGUIb (0.7.1), which all worked perfectly
for me with Ruby 1.8.4 as did foxGUIb. So, when I launch foxGUIb now I
get literally hundreds of error messages (see below), although foxGUIb
does ultimately come up. Anyone know what I’m missing or did wrong?
Perhaps foxGUIb v0.7.1 is not “certified” on Ruby 1.8.5 (I googled this
and searched all the other likely suspects but didn’t find anything.)

Thanks in advance for any help you can lend!

Ken

<snip - all the errors are of this type>

/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_HIDE_FILES
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_TOGGLE_FILES
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SHOW_HIDDEN
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_HIDE_HIDDEN
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_TOGGLE_HIDDEN
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SET_PATTERN
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SORT_REVERSE
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SORT_CASE
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_REFRESH
/usr/local/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_LAST

On 11/2/06, Kenosis [email protected] wrote:

I decided to step up to Ruby 1.8.5 today. After installing 1.8.5, I
completely uninstalled and reinstalled fox (1.6.16), fxscintilla
(1.71), FXRuby (1.6.3), and foxGUIb (0.7.1), which all worked perfectly
for me with Ruby 1.8.4 as did foxGUIb. So, when I launch foxGUIb now I
get literally hundreds of error messages (see below), although foxGUIb
does ultimately come up. Anyone know what I’m missing or did wrong?
Perhaps foxGUIb v0.7.1 is not “certified” on Ruby 1.8.5 (I googled this
and searched all the other likely suspects but didn’t find anything.)

Thanks in advance for any help you can lend!

This is a known bug in Ruby 1.8.5; see:

http://rubyforge.org/tracker/?func=detail&aid=5701&group_id=426&atid=1698

Hope this helps,

Lyle

Until the 1.8.5 bug is fixed, just precede the “require” with: $VERBOSE
= nil

example:
$VERBOSE = nil # ruby 1.8.5 bug work-around
require ‘fox12’
$VERBOSE = true

NoonKnight wrote:

Until the 1.8.5 bug is fixed, just precede the “require” with: $VERBOSE
= nil

example:
$VERBOSE = nil # ruby 1.8.5 bug work-around
require ‘fox12’
$VERBOSE = true

Thanks to all - much appreciated.

Ken

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs