Form_remote_tag params not passed .. PLEASE help!


#1

This problem is driving me nuts

Here is my code for the view:

coming soon!
Email address:
<%= form_remote_tag(:update => 'result', :url => { :controller => 'launch', :action => 'process_email' }, :with => "'blah=' + escape(value)", :complete => "Element.hide('eid');Element.hide('sub');Element.show('result')", :position => "top") %> <%= end_form_tag %>

Here is my controller code:

class LaunchController < ApplicationController
layout “launch-layout”
def index
end
def process_email
render_text @params.inspect
end
end

It only prints out {“action”=>“process_email”, “controller”=>“launch”}

The parameters DONT SHOW UP!!!

I have <%= javascript_include_tag “prototype” %> in my layout.

where am I screwing up???

PLEASE HELP!


#2

what is even more scary is the production.log generates the following

Processing LaunchController#process_email (for x.u.x.h at 2006-02-23
16:26:50) [GET]
Parameters: {“action”=>“process_email”, “controller”=>“launch”}
Response body was encoded with gzip
Completed in 0.00327 (305 reqs/sec) | 200 OK

Doesnt show the parameters! is something wrong with my view code??


#3

rubynewbie wrote:

=====
It only prints out {“action”=>“process_email”, “controller”=>“launch”}

The parameters DONT SHOW UP!!!

You probably want

            :with => "'blah=' + escape($F('blah'))",

or remove the :with option and escape at the server.


We develop, watch us RoR, in numbers too big to ignore.


#4

rubynewbie wrote:

:with was added to see if the parameter would be passed … The problem
is this requested should be generating a POST on the server its
generating a GET! Weird!

Ah, OK. Look at the source of the generated HTML to make sure prototype
is being included.


We develop, watch us RoR, in numbers too big to ignore.


#5

Mark Reginald J. wrote:

rubynewbie wrote:

=====
It only prints out {“action”=>“process_email”, “controller”=>“launch”}

The parameters DONT SHOW UP!!!

You probably want

            :with => "'blah=' + escape($F('blah'))",

or remove the :with option and escape at the server.


We develop, watch us RoR, in numbers too big to ignore.

:with was added to see if the parameter would be passed … The problem
is this requested should be generating a POST on the server its
generating a GET! Weird!