Floating point exception (core dumped)

Hello list,

1/ I have been stuck into debugging process of some code,
Am getting a: ‘Floating point exception (core dumped)’ which pop up
randomly:

In other words, I have tried to find out was that related really to an
arithmetic error of division by zero, and I fixed all possibilities of
getting the error because of that, however now every possibility of
getting
division by zero is eliminated I still get the error and worse every
time am
running the code I get the exception raised from a different place.
Reading more on that exception on GR forum, I did not understood how
could
connecting a packet modulator with a USRP sink, raise such exceptions,

(the context is as follows: a “mod_pkts_sptr” connected to “usrp_sink”
Inside the section of
“mod_pkts_sptr”
there is a thread generating packets and sending them continuously)

Please, if there is any hints or explanations I will be very pleased,
2/ Apart from that is there any accurate way to ask gdb to locate
exactly
which instruction is erroneous or which section of the code is causing
trouble.

3/ Is that a correct way to connect foo block to a currently described
block:

opaque_self gr_hier_block2_self();
connect(foo, 0, self(), 0);

Regards,


View this message in context:
http://gnuradio.4.n7.nabble.com/Floating-point-exception-core-dumped-tp43810.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Hi again,

I just realized how to pinpoint the erroneous section from gdb,
by doing ‘gdb --core=mycoredump ./NeoTx’
>gdb run

It was the “gr_diff_encoder_bb::work” which cause the exception,
I am not initializing the variable of the modulus (the parameter to
gr_make_diff_encoder_bb).


View this message in context:
http://gnuradio.4.n7.nabble.com/Floating-point-exception-core-dumped-tp43810p43813.html
Sent from the GnuRadio mailing list archive at Nabble.com.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs