Flickr demo screencast


#1

Hi,

I’m new to Ruby and Ruby on Rails. Yesterday I just received the Agile
Web D. with Rails book.

Now I wanted to recreate the Flickr demo screencast
(http://www.rubyonrails.com/screencasts) just for fun to see it live.
But unfortunately when I start my server I get some warnings:

g5:~/ruby/flickr mw$ ruby script/server
=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach (requires absolute paths in
config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:274:
warning: already initialized constant KNOWN_OPTIONS
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:279:
warning: already initialized constant DEF_KEY_ATTRIBUTES
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:280:
warning: already initialized constant DEF_ROOT_NAME
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:281:
warning: already initialized constant DEF_CONTENT_KEY
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:282:
warning: already initialized constant DEF_XML_DECLARATION
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:283:
warning: already initialized constant DEF_ANONYMOUS_TAG
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:284:
warning: already initialized constant DEF_FORCE_ARRAY
/usr/local/lib/ruby/gems/1.8/gems/xml-simple-1.0.7/lib/xmlsimple.rb:285:
warning: already initialized constant DEF_INDENTATION

This is how I installed the gems:

g5:~/ruby/flickr mw$ sudo gem install -r flickr
Attempting remote installation of ‘flickr’
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency xml-simple? [Yn] Y
Successfully installed flickr-1.0.0
Successfully installed xml-simple-1.0.7

Moreover, when I access http://localhost:3000/flickr, the page is blank!
But I have all the same files in the same categories like in the
screencast. What’s the deal?

Thanks for your patience and responses in advance.

Michal


#2

Maybe this will help:

Ruby version 1.8.4 (powerpc-darwin8.4.0)
RubyGems version 0.8.11
Rails version 1.0.0
Active Record version 1.13.2
Action Pack version 1.11.2
Action Web Service version 1.0.0
Action Mailer version 1.1.5
Active Support version 1.2.5
Application root /Users/mw/ruby/flickr
Environment development
Database adapter mysql


#3

I have those warnings on my dev setup as well when running an app that
gets images from Flickr but it still runs fine. I can’t figure out
where the bug is but it shouldn’t effect how things run. Just
annoying at startup.

Your blank page is probably due to something else like not being able
to connect to your database. Check your database.yml settings. Even
if your page doesn’t call the database, the app will fail if it can’t
access the database server.

Mike


#4

Michael E. wrote:

Your blank page is probably due to something else like not being able
to connect to your database. Check your database.yml settings. Even
if your page doesn’t call the database, the app will fail if it can’t
access the database server.

Thanks, that might have been the case. Something had to be wrong with
MySQL. After I restarted it and launched the webserver again, everything
went fine. Thanks!