Flickr controller

I posted about the flickr controller not working a few days ago… the
stack trace lead me to believe that the latest patch that was merged
might be cause for the problem…

private method gsub' called for {}:Hash (NoMethodError) /usr/lib/ruby/1.8/cgi.rb:370:inunescapeHTML’
…/config/…/components/plugins/textfilters/flickr_controller.rb:58:in
`macrofilter’

http://www.typosphere.org/trac/attachment/ticket/955/text_filter_flickr_controller.patch

It changes this line:
caption ||= flickrimage.description
to
caption ||= sanitize(CGI.unescapeHTML(flickrimage.description))

I was looking at CGI.unescapeHTML(string) and I don’t think it plays
with nulls very well… in fact, it calls string.gsub in the first line
of the method (which is what the exception in the trace came from).
http://www.ruby-doc.org/core-1.9/classes/CGI.src/M000419.html

Now, I’m not verse in Ruby… so I’m not sure how to go about fixing this
or if this is even the problem…

I backed up that file to the previous revision and things are working
fine…

Thanks,
Jake

Ah, that’s probably the problem. Can you test revision 1111 and see if
it
works?

Scott

Still the same error as before…

hrmpf, I would assume that should have changed it…

It’s definitely THAT exact line that’s messing things up.

1112 fixed it!

Thanks Scott

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs