Flash Filereference and Rails - getting http 422


#1

I’ve spent the last few days trying to figure this out. I have my own
Filereference class I use with PHP. But I’m trying to use it with
Rails and can’t seem to get it to work. I even downloaded some samples
online and can’t get those to work (http://blog.vixiom.com/2006/09/08/
multiple-file-upload-with-flash-and-ruby-on-rails/).

Basically my rails is something like this:

data = params[:filedata]
name = params[:Filename]

directory = "public/data"

  path = File.join(directory, name)
  File.open(path, 'wb') do |file|
    file.puts data.read
  end

And when I use filereference and upload it in flash I get an
httpError: 422
I get this both in mine and the example’s file.


#2

Anyone know what the answer might be? Or an up to date link that
explains?


#3

Hmm. I think it may be something with the Authenticity Token. I think
I need to bypass it…


#4

K I figured out how to fetch and send the AuthToken… It’s still now
working.

Anyone have any idea, or a resource for Flash file uploading to Rails
2.x?


#5

Have you tried the “Flash 8 for Windows” fix on the blog page you
linked? Without any more details about your environment, that’s the
first thing I’d suspect. Not sure how that fix will interact with the
new Rack stuff in 2.3, though.

–Matt J.


#6

I didn’t, but I’m running on a Mac, so I figured it wouldn’t matter…
Plus that post is 3 years old!


#7

oops, I meant still NOT working**

Any ideas?