Fixtures in Jruby Mysql

Hi,

I’ve been developing a Rails frontend to a Java backend which is working
great. I’m running into trouble now that I’m adding a few models though.

All specs that use fixtures fail. Jruby gives this error message in the
Rspec version of two weeks ago:

java.sql.SQLException: Can’t call rollback when autocommit=true

I’ve just now updated to the newest CURRENT version of Rspec and the
specs now fail silently. I can only assume it’s still the same problem
:-).

I’ve tried adding ?autoCommit=false to the Jdbc url and I’ve set
config.use_transactional_fixtures to false. Neither of these changes
seem to have any effect. There seems to be extremely little information
available about this issue through Google.

Does anybody have any ideas?

Thijs

I just realized I made a mistake in the description of the problem. The
specs don’t fail, but crash. Nothing after the fixtures line in the spec
is executed.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs