Fixtures don't load on functional tests with 'rake test:functionals' (but do with ruby!)

I’ve got a problem that I’ve been hurting my brain on for a little

When I run my two functional tests using

% ruby thing_ones_controller_test.rb
% ruby thing_twos_controller_test.rb

they work fine.

If I run

% rake test:functionals

and either ONE of them is in the functional directory it works fine as
well. However when both are in the functional directory the first
functional test fails because the fixtures don’t get loaded. WTF^^?

All unit tests pass fine (and load fixtures) as well if I do “rake
test:units” and I’ve never had trouble with them.

I’m running Ruby 1.8.4, Rails 1.2.3, Rake 0.7.2.

Anyone else fight this battle?

Okay, hopefully this will help someone someday… don’t copy and paste
the code from a working functional test and forget to change the
requires and classes. D’oh.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs