Fixing Watir Problem, was Re: Watir is acting retarded


#1

Daniel,

Should we release a new Watir gem installer that requires these updated
files?

Bret


#2

On Feb 5, 6:38 pm, Bret P. removed_email_address@domain.invalid wrote:

[Note: parts of this message were removed to make it a legal post.]

Daniel,

Should we release a new Watir gem installer that requires these updated
files?

Wouldn’t hurt I suppose. It would probably be less confusing.

Sorry for the trouble.

Regards,

Dan


#3

Daniel,

I updated the gemspec for Watir and distributed a new gem (privately)
but it
did not fix this problem. My understanding is that bad gems were
released
and then new gems were released with the same version numbers. Is this
true?

If it is, then the only reliable solution would be for you to re-release
the
fixed gems with an incremented version number. This is the only way that
the
gem system will be sure to update people who have the bad gems.

We are getting more and more complaints about this, and the current
solution
is very complicated to explain to people, so I would appreciate your
help in
finding a simple solution.

I’m not sure I really understand the situation. If not, I would
appreciate
clarification.

Bret

On Thu, Feb 5, 2009 at 10:39 PM, Daniel B. removed_email_address@domain.invalid
wrote:

Sorry for the trouble.

win32-api 1.3.0 or later

Bret P.
GTalk: removed_email_address@domain.invalid
CTO, WatirCraft LLC,http://www.watircraft.com
Lead Developer, Watir,http://wtr.rubyforge.org
Blog (Essays),http://www.io.com/~wazmo/bloghttp://www.io.com/~wazmo/blog
MiniBlog (Links),http://feeds.feedburner.com/bretshotlist


Bret P.
GTalk: removed_email_address@domain.invalid
CTO, WatirCraft LLC, http://www.watircraft.com
Lead Developer, Watir, http://www.watir.com
Blog (Essays), http://www.io.com/~wazmo/blog
MiniBlog (Links), http://feeds.feedburner.com/bretshotlist
Training, http://www.watircraft.com/watir-training