First-timer Question

Since my last question (which was on installing GNU Radio on VM-ware) I
have abandoned that approach and now am trying it out on an actual
I apologize in advance if this question seems too long, I’m just going
to walk through everything I did to get to where I am now
(so in the process it might even turn out to be a resource for other
first-timers who are having problems)
I’m using fedora 8 (and through out this the USRP board is not plugged

So after going through a brand new Fedora 8 installation, to get a
working GNU Radio I first did this:
$ yum isntall gnuradio

since I wasn’t sure what exactly had happened, I kind of disregarded it
and continued with this path:

did this:
$ yum install sdcc

then did these:
$ yum groupinstall “Engineering and Scientific” “Development Tools”
$ yum install fftw-devel cppunit-devel wxPython-devel libusb-devel guile
boost-devel alsa-lib-devel numpy

then added these two manually to “/home/[user]/.bashrc”:


then I restart the computer for the changes to take effect
then I finish it off by doing theses:

$ svn co gnuradio
$ cd gnuradio
$ ./bootstrap
$ ./configure
$ make
$ make check
$ sudo make install

all the installation worked as it should.
BTW: after the ./configure I get this (which seems normal):

The following components were skipped either because you asked not
to build them or they didn’t pass configuration checks:


Now for a test I ran this:
$ cd /gnuradio-examples/python/audio/
$ python

Which gives me this error:

audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid 

Traceback (most recent call last):
File “”, line 55, in
File “”, line 48, in init
dst = audio.sink (sample_rate, options.audio_output)
File “/usr/lib/python2.5/site-packages/gnuradio/”,
line 236, in sink
return _audio_alsa.sink(*args)
RuntimeError: audio_alsa_sink

I had seen this error before and the cause of it (as I had found on
theses forums) was another program (youtube’s video player in browser)
using up the sound device. so by closing down FireFox it worked, but now
it makes no difference. I know my sound device works (as I was able to
play a song fine)
but I’m getting really frustrated (due to the non-ending steps just to
get GNU Radio running and to some degree my lack of fully understanding
the linux architecture). Any help would be appreciated.

My next question would be (if I managed to somehow resolve the prev.
problem) to actually hook up the USRP to the machine, what steps do I
have to take to ensure the software can communicate with the hardware? I
found this page:

but does this page still exist somewhere on this website (hopefully with
updated info.) or if it does not, why not?

Thanks you all.

I have just installed gnuradio onto Fredora 8.
I installed Fedora 8.
Connected to the internet.
Let Fedora do its automatic updates.
I then ran the following command

yum install gnuradio

There were about 10 dependent packages that needed to be installed.

Once all the downloads were finished I had gnuradio installed.

The gnuradio examples were in a separate package.

From memory I think the command to install it was

yum install gnuradio-examples.

Notes on my install

I was running Fedora 8 as a virtual machine in VMware.
I also installed GnuRadio Companion (grc) well worth while.
The install was done without a usrp connected.

Hope this helps
On Wed, 21 May 2008 21:00:22 +0000, “Mr. mollasadra”
[email protected] said:

On Wed, May 21, 2008 at 11:28:54PM +0000, Cameron Moore wrote:


I’m pretty sure Fedora 8 ships with Python 2.5.





  File "", line 55, in <module>
  File "", line 48, in __init__
    dst = audio.sink (sample_rate, options.audio_output)
  File "/usr/lib/python2.5/site-packages/gnuradio/",
  line 236, in sink
    return _audio_alsa.sink(*args)
RuntimeError: audio_alsa_sink


./dial_tone -O plughw:0,0



I will be trying to connect a usrp to a virtual machine this weekend, I
will let you know what happened.
I do know from previous experience that the usrp can send data at a
higher data rate than a virtual machine can handle, so there is a lot of
over run errors.
I only use vm’s for testing.
By the way we should communicate via the discussion list, as other
people may be interested in what we are talking about.

On Thu, 22 May 2008 22:54:31 +0000, “Mr. mollasadra”
[email protected] said:

for the sake of archive.

Hey George,

I remember when I had the same exact problem as you, trying to install
gnuradio on a virtual machine for the convenience
(had to switch to FC5 to make sure GNU radio on VMware was possible, and
surely it was) until I finally decided to use a native system instead
(as you might know the limitation that a virtual machine imposes on
gnuradio in general just make it not worth it).

As Cameron has said in the parent posts, to install gnuradio the easy
way on a fresh installation of FC8 (instead of going through and making
is to do:

$ yum install gnuradio
$ yum install gnuradio-examples

that worked for me. The path where it installed the examples for me was:


and if you try out “audio/”, it should work.
now the next step - at least for me - was to get the USRP board to
communicate with GNU radio so for example
“usrp/” would work, and for that I’m waiting for
Cameron’s answer again.

hope that helped.


I will appreciate if you have any suggestions.



Keep your kids safer online with Windows Live Family Safety.

OK, I think I found what I had been looking for:

Thanks to all, specially Cameron for their help.

Yes, I have made some progress.
I have the usrp working with virtualized Fedora. The biggest problem I
have was getting the virtual machine to see the usrp on the usb bus. The
linux command “lsusb” will show the usrp on the bus.
As you would expect the max through put on the usb port was around 16MB,
determined using
I did some other testing using, set your frequency and
then set the volume using the -V option I had to set it to 50.

On Fri, 30 May 2008 16:48:14 +0000, “Mr. mollasadra”
[email protected] said: