Firebird adapter HELP?


#1

Hi All,

Is anyone successfully using ROR 2.x with Firebird 2.x in a production
environment? The support seems to have dwindled.

I would greatly appreciate any installation guidelines, comments or
tips. What is somewhat confusing is what is required to for ROR to play
nicely with firebird.

I have come across fireruby, fb_adapter, fb-0.5.9…there does not seem
to be cohesive install / requirement steps…I certainly don’t mind
working through all this but would appreciate any help to nudge me
along.

Thanks,
Rick


#2

On Tue, Mar 31, 2009 at 2:50 PM, Rick F.
removed_email_address@domain.invalid wrote:

I have come across fireruby, fb_adapter, fb-0.5.9…there does not seem
to be cohesive install / requirement steps…I certainly don’t mind
working through all this but would appreciate any help to nudge me
along.

Hi Rick,

I actually asked the same question a while ago
http://www.ruby-forum.com/topic/181473. And as you can see there was
no answers for that. But, after some trial and error I managed to get
it to work.

Before I posted the thread asking for help, I went through the
following tutorial
http://mapopa.blogspot.com/2009/02/installing-firebird-active-record-for.html,
but I did not get it to work, and that is when I got that error
message. But, I found out what was missing.

I installed it under Ubuntu Linux, and first I made sure that
libfbclient.so was in /usr/lib. In other words, if you installed from
the repository, then make sure that you install firebird-dev. I always
install from the archives.

Next, you do the following:

  1. install fb-0.5.9
  2. install fb_adapter
  3. go to the folder where fb-0.5.9 is (in my case it is under
    /usr/lib/ruby/gems/1.8/gems/fb-0.5.9), and do a sudo make install.
    That should install fb-0.5.9.

That’s it, you can now follow the rest of the tutorial from
http://mapopa.blogspot.com/2009/02/installing-firebird-active-record-for.html

Migrations aren’t yet working.

Good luck!

Fidel.


#3

On Tue, Mar 31, 2009 at 3:12 PM, Fidel V. removed_email_address@domain.invalid
wrote:

That’s it, you can now follow the rest of the tutorial from
http://mapopa.blogspot.com/2009/02/installing-firebird-active-record-for.html

Sorry, wrong link. Here is the correct one
http://mapopa.blogspot.com/2009/02/rails-on-firebird-status-after-adapter.html

All the best,

Fidel.


#4

Thanks for sharing the knowledge, you’re a life-saver.

Best regards,
Rick


#5

On Tue, Mar 31, 2009 at 6:20 PM, Rick F.
removed_email_address@domain.invalid wrote:

Thanks for sharing the knowledge, you’re a life-saver.

No problem. I am working on the code to add support for migrations,
and will share that as well soon. Right now, I am able to do some
migrations, but I still have to do a fair bit of testing. I am not
really a Ruby expert, so it takes a little more time, because I have
to read about certain features.

Anyway, I will share after I finish.

All the best,

Fidel.


#6

Does anyone have an example of how to connect to a database and execute
a simple query using Ruby?


#7

Adrian Marius Popa wrote in post #1078698:

On Wednesday, October 3, 2012 10:37:26 PM UTC+3, Ruby-Forum.com User
wrote:

Does anyone have an example of how to connect to a database and execute
a simple query using Ruby?

I have explained at the end of the article
http://mapopa.blogspot.ro/2009/02/fireruby-howto-start-with-firebird-and.html

All you need to do is to install firebird2.5-dev headers and after that
gem install fb should do all the work for you

I recommend to use rvm and a current ruby 1.9.3

Thanks for your reply, I read your blog. Only what i need connect to
firebird from Windows.


#8

On Wednesday, October 3, 2012 10:37:26 PM UTC+3, Ruby-Forum.com User
wrote:

Does anyone have an example of how to connect to a database and execute
a simple query using Ruby?

I have explained at the end of the article
http://mapopa.blogspot.ro/2009/02/fireruby-howto-start-with-firebird-and.html

All you need to do is to install firebird2.5-dev headers and after that
gem install fb should do all the work for you

I recommend to use rvm and a current ruby 1.9.3


#9

On Friday, October 5, 2012 3:16:25 PM UTC+3, Ruby-Forum.com User wrote:

I have explained at the end of the article

I don’t use windows but my guess is you need devkit from rails installer
also the firebird headers

http://railsinstaller.org/

ps: on windows usually it’s easier to install ubuntu in a virtualbox and
work from there
I will try to write some steps for the railsinstalller+devkit
installations
and firebird