FileColumn and/or RMagick woes


#1

I installed the latest version of the FileColumn plugin last night and
when I go to upload an image an error is returned saying the file is not
of a valid image type. I don’t remember the exact verbage.

My system is Fedora Core 3. I have installed RMagick via the gem
available at RubyForge. It appears that I have ImageMagick installed.

I’m a Linux newbie and I’m really unsure of what the cause might be. Any
help is greatly appreciated.

Thanks!


#2

I had this problem when ImageMagick didn’t have the correct converters
installed. You need converters for the image types you are going to
support.
In my case that meant JPEG support.

You can test if that is the problem by using the identify command line
tool
on an image of the type you’re trying to work with. My guess is that
your
ImageMagick isn’t installed the way you think it is.

Anyway, start there.


#3

The pain still continues.

I have tried every tutorial for installing ImageMagick and RMagick that
I
can find (most are all pretty similar). I have installed ImageMagick
with
JPEG support, I tested this using the identify command on a jpeg image,
it
reported back properly…

…yet when I try to upload a jpeg image using the FileColumn library it
fails with an “invalid image” error. If I upload a gif image everything
works.

I don’t know what to try next. Does anyone have any suggestions?

Kyle H.
removed_email_address@domain.invalid


#4

Do you have the JPEG libs installed on your system? Sounds like the
issue. I
used to have a similar problem when using Perl/PerlMagick and trying to
maniupate PNG images without libpng installed.


#5

I built them, successfully I believe. Wouldn’t being able to run
identify on
a jpeg indicate that they are installed or is that misleading?

If that isn’t the case how can I determine if they are installed and if
not,
where do I get them and how should I install them (to minimize
headaches).

Thanks for the reply.

Kyle H.
removed_email_address@domain.invalid


From: Adam R. [mailto:removed_email_address@domain.invalid]
Sent: Wednesday, November 09, 2005 11:39 PM
To: removed_email_address@domain.invalid; removed_email_address@domain.invalid
Subject: Re: [Rails] FileColumn and/or RMagick woes

Do you have the JPEG libs installed on your system? Sounds like the
issue. I
used to have a similar problem when using Perl/PerlMagick and trying to
maniupate PNG images without libpng installed.

On 11/9/05, Kyle H. removed_email_address@domain.invalid wrote:

The pain still continues.

I have tried every tutorial for installing ImageMagick and RMagick that
I
can find (most are all pretty similar). I have installed ImageMagick
with
JPEG support, I tested this using the identify command on a jpeg image,
it
reported back properly…

…yet when I try to upload a jpeg image using the FileColumn library it
fails with an “invalid image” error. If I upload a gif image everything
works.

I don’t know what to try next. Does anyone have any suggestions?

Kyle H.
removed_email_address@domain.invalid