File_column path problem grouping controllers in to modules


#1

Hey there,
good job with the file_column thing, but I’m experiencing a problem I
didn’t found about.
I’m grouping controllers in to modules (like Admin::Category Admin:Item)
and:
url_for_file_column(“dettaglio”, “picture_url”)
return this search path:
src="/detail/picture_url/development/5/dark.jpg"
there’s a development coming from nowhere… well probably it does
come from somewhere but I didn’t get why and how… :slight_smile: I’m trying to
find a way around so if you have some suggestions any help is
apreciated.
Thank you very much.
Enrico


“The only thing necessary for the triumph of evil
is for good men to do nothing”
Edmund Burke


#2

Hey I’ve tried creating a brand new project where I was creating the
same environment (a scaffold on a table controlled my a controller
like Admin::Handler accesed trough salted_login_generator).
I’ve tried wondering what were the problem on the other side… I’ve
burned a .NET reference manual and from the cinders I’ve read… try
to remove the
before_filter :login_required
from the faulty controller… you know what? It worked!
After then I’ve reinserted it cause I needed it and it worked. I’ve
resetted the session many times before this last move but nothing ever
solved.

here’s two routes I’m using for entering in another controller (item)
placed within admin.
map.connect ‘admin’,
:controller => “admin/item”,
:action => “index”
map.connect ‘admin/user/:action’,
:controller => “user”
I’ve removed them too… and reinsterted… I’m really clueless.
Enrico


“The only thing necessary for the triumph of evil
is for good men to do nothing”
Edmund Burke


#3

Hi Enrico,

On 2/4/06, Enrico T. removed_email_address@domain.invalid wrote:

good job with the file_column thing, but I’m experiencing a problem I
didn’t found about.
I’m grouping controllers in to modules (like Admin::Category Admin:Item) and:
url_for_file_column(“dettaglio”, “picture_url”)
return this search path:
src="/detail/picture_url/development/5/dark.jpg"
there’s a development coming from nowhere… well probably it does
come from somewhere but I didn’t get why and how… :slight_smile: I’m trying to
find a way around so if you have some suggestions any help is
apreciated.

I believe your are using an old version of file_column (from Kyle’s
branch, to be more exact) that exhibited this behaviour. If you use
the latest release or the version from the trunk, “development”
shouldn’t show up in your URL.

Sebastian