FFTW Problems

I’m trying to build with the latest svn source as of this past weekend
in FC 4. below is a snip of my configure and make outputs
… Can someone help me with this please - I’m getting unresolved
externals on FFTW -
…Ron
---------------------------------- snip
configure:27346: result: no
configure:27360: checking for dot
configure:27387: result: NO
configure:27401: checking for pkg-config
configure:27419: found /usr/bin/pkg-config
configure:27432: result: /usr/bin/pkg-config
configure:27453: checking for fftw3f >= 3.0
configure:27457: result: yes
configure:27461: checking FFTW3F_CFLAGS
configure:27464: result: -I/usr/local/include
configure:27467: checking FFTW3F_LIBS
configure:27470: result: -L/usr/local/lib -lfftw3 -lm
configure:27473: checking FFTW3F_INCLUDEDIR
configure:27476: result: /usr/local/include
configure:27664: checking for machine dependent speedups
configure:27672: result: x86
configure:27743: checking for cppunit-config
configure:27761: found /usr/local/bin/cppunit-config
configure:27774: result: /usr/local/bin/cppunit-config
configure:27783: checking for Cppunit - version >= 1.9.14
configure:27816: result: 1.12.0
configure:28037: checking boost/shared_ptr.hpp usability
configure:28049: g++ -c -g -O2 -Wall -Woverloaded-virtual -pthread
conftest.cc >&5
configure:28055: $? = 0
-------------------------- end snip
make[6]: Leaving directory
/home/shaffer/gnuradio/gnuradio-core/src/lib/swig' make[5]: Leaving directory/home/shaffer/gnuradio/gnuradio-core/src/lib/swig’
make[4]: Leaving directory
/home/shaffer/gnuradio/gnuradio-core/src/lib' Making all in tests make[4]: Entering directory/home/shaffer/gnuradio/gnuradio-core/src/tests’
/bin/sh …/…/…/libtool --tag=CXX --mode=link g++ -g -O2 -Wall
-Woverloaded-virtual -pthread -o benchmark_dotprod
benchmark_dotprod.o …/…/…/gnuradio-core/src/lib/libgnuradio-core.la
g++ -g -O2 -Wall -Woverloaded-virtual -pthread -o
.libs/benchmark_dotprod benchmark_dotprod.o
…/…/…/gnuradio-core/src/lib/.libs/libgnuradio-core.so -lrt
-L/usr/local/lib -Wl,–rpath -Wl,/usr/local/lib

undefined references here on fftwf_
.*
make[4]: Leaving directory
/home/shaffer/gnuradio/gnuradio-core/src/tests' make[3]: Leaving directory/home/shaffer/gnuradio/gnuradio-core/src’
make[2]: Leaving directory /home/shaffer/gnuradio/gnuradio-core' make[1]: Leaving directory/home/shaffer/gnuradio’
------------------------------- end


Ron Shaffer’s Hamshack Computer
Amateur: W4VM / MARS: AAT4SJ

ARC President & Assistant Frequency Coordinator
http://www.alabamarepeatercouncil.org

IRLP NODE 4950 / http://www.qsl.net/w4vm
443.475, 443.250 and 147.10 Repeaters Huntsville

On Thu, Sep 21, 2006 at 05:51:31PM -0500, Ron Shaffer wrote:

I’m trying to build with the latest svn source as of this past weekend
in FC 4. below is a snip of my configure and make outputs
… Can someone help me with this please - I’m getting unresolved
externals on FFTW -
…Ron

You don’t have a version of FFTW installed that includes the single
precision versions.

The easiest way to fix it is to build fftw from source as described in
the README at the top of the gnuradio tree.

(3)  FFTW 3.0 or later	      http://www.fftw.org

IMPORTANT!!!  When building FFTW, you MUST use the --enable-single 

and
–enable-shared configure options. This builds the single precision
floating point version which we use. You should also use either the
–enable-3dnow or --enable-sse options if you’re on an Athlon or
Pentium
respectively.

Eric

Eric B. wrote:

floating point version which we use. You should also use either the
–enable-3dnow or --enable-sse options if you’re on an Athlon or Pentium
respectively.

and the latter bits have a large impact on the speed so be sure and
enable the simd instruction codelets in FFTW.


Robert W. McGwier, Ph.D.
Center for Communications Research
805 Bunn Drive
Princeton, NJ 08540
(609)-924-4600
(sig required by employer)

Eric B. wrote:

floating point version which we use. You should also use either the
–enable-3dnow or --enable-sse options if you’re on an Athlon or Pentium
respectively.

The latter bits have a large impact on the speed so be sure and enable
the simd instruction codelets in FFTW. In fact, you can enable BOTH,
and FFTW will just do the right thing. I never trust that the default
included packages in the distro’s have these flags turned on during the
compile. I always replace FFTW with my own compile from source in self
defense.

Eric


Robert W. McGwier, Ph.D.
Center for Communications Research
805 Bunn Drive
Princeton, NJ 08540
(609)-924-4600
(sig required by employer)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs