Ferret installation woes


#1

Ferret installation fails for me (ferret: 0.10.14, ruby: 1.8.4, OS:
Fedora Core 4) in the following way:

ruby setup.rb setup

In file included from r_qparser.c:2:
search.h:714: field `comparables’ has incomplete type
make: *** [r_qparser.o] Error 1
The C extensions were not installed. But don’t worry. Everything should
work fine

ruby setup.rb install

—> ext
no ruby extention exists: ‘ruby setup.rb setup’ first

Any ideas? Installing via ‘gem install ferret’ just gives the
‘comparables’ error, I figured this would be more informative.


#2

Just in case someone else runs into this: what ended up working was
changing comparables[] on that line to comparables[1], and positions[]
to positions[1] in some other file.


#3

On Fri, Jan 26, 2007 at 07:33:19PM +0100, Jonathan Soma wrote:

Just in case someone else runs into this: what ended up working was
changing comparables[] on that line to comparables[1], and positions[]
to positions[1] in some other file.

strange, what kind of compiler do you have there?

Jens


webit! Gesellschaft für neue Medien mbH www.webit.de
Dipl.-Wirtschaftsingenieur Jens Krämer removed_email_address@domain.invalid
Schnorrstraße 76 Tel +49 351 46766 0
D-01069 Dresden Fax +49 351 46766 66