Fedora core 5 and tcltklib

I have fedora Core 5 running on two machines (both pentium 4 dual boot
machines).

I have installed ruby (ruby 1.8.4 (2005-12-24) [i386-linux]) and
ruby tk (ruby-tcltk-1.8.4).

When I run irb and add require ‘tk’. This is the error message I
receive.

/usr/lib/ruby/1.8/tk.rb:1102: warning: Inconsistency.
Loaded Tcl/Tk libraries are enabled nativethread-support.
But `tcltklib’ is not. The inconsistency causes SEGV or other troubles
frequently.

This error is present on both machines.

Is there some way of correcting this problem.

thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs