Fedora 9 / Panic

I’m getting the following error in the error.log:
panic: MUTEX_LOCK (22) [op.c:453].

nginx -v
nginx version: nginx/0.6.31

uname -a
Linux woot 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64
x86_64 x86_64 GNU/Linux

gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: …/configure --prefix=/usr --mandir=/usr/share/man –
infodir=/usr/share/info
–with-bugurl=http://bugzilla.redhat.com/bugzilla
–enable-bootstrap --enable-shared --enable-threads=posix --enable-
checking=release --with-system-zlib --enable-__cxa_atexit --disable-
libunwind-exceptions --enable-languages=c,c++,objc,obj-c+
+,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-
plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre –
enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/
usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-
cpu=generic --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC)

Any insight would be appreciated :slight_smile:
Thanks !

Hi,

I see this in my error log as well, and it appears to happen only when
I
restart nginx… It does mean sometimes the restarts fail.

-Todd

How did you restart nginx ?

2008-07-23

Chancey

发件人: Todd F.
发送时间: 2008-07-23 20:30:09
收件人: [email protected]
抄送:
主题: Re: Fedora 9 / Panic

Hi,

I see this in my error log as well, and it appears to happen only when
I restart nginx… It does mean sometimes the restarts fail.

-Todd

On Wed, Jul 23, 2008 at 1:45 AM, Dylan S. [email protected]
wrote:

I’m getting the following error in the error.log:
panic: MUTEX_LOCK (22) [op.c:453].

nginx -v
nginx version: nginx/0.6.31

uname -a
Linux woot 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64 x86_64
x86_64 GNU/Linux

gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: …/configure --prefix=/usr --mandir=/usr/share/man
–infodir=/usr/share/info
–with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap
–enable-shared --enable-threads=posix --enable-checking=release
–with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions
–enable-languages=c,c++,objc,obj-c++,java,fortran,ada
–enable-java-awt=gtk --disable-dssi --enable-plugin
–with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre
–enable-libgcj-multifile --enable-java-maintainer-mode
–with-ecj-jar=/usr/share/java/eclipse-ecj.jar
–disable-libjava-multilib --with-cpu=generic
–build=x86_64-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC)

Any insight would be appreciated :slight_smile:
Thanks !

On Wed, Jul 23, 2008 at 05:45:54PM +1200, Dylan S. wrote:

I’m getting the following error in the error.log:
panic: MUTEX_LOCK (22) [op.c:453].

nginx -v
nginx version: nginx/0.6.31

uname -a
Linux woot 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64
x86_64 x86_64 GNU/Linux

This message is issued by perl. I had fixed it once.
However, I do not know the cause of modern message.

Using the init.d scripts

Source function library.

. /etc/rc.d/init.d/functions

Source networking configuration.

. /etc/sysconfig/network

Check that networking is up.

[ “$NETWORKING” = “no” ] && exit 0

nginx="/usr/sbin/nginx"
prog=$(basename $nginx)

NGINX_CONF_FILE="/etc/nginx/nginx.conf"

[ -f /etc/sysconfig/nginx ] && . /etc/sysconfig/nginx

lockfile=/var/lock/subsys/nginx

start() {
[ -x $nginx ] || exit 5
[ -f $NGINX_CONF_FILE ] || exit 6
echo -n $"Starting $prog: "
daemon $nginx -c $NGINX_CONF_FILE
retval=$?
echo
[ $retval -eq 0 ] && touch $lockfile
return $retval
}

stop() {
echo -n $"Stopping $prog: "
killproc $prog -QUIT
retval=$?
echo
[ $retval -eq 0 ] && rm -f $lockfile
return $retval
}

restart() {
configtest || return $?
stop
start
}

I guess … it couldn’t full stop nginx daemon and then create new
process .
you can try edit the script like this and try restart again:

restart() {
configtest || return $?
stop
sleep 2
start
}

2008-07-24

Chancey

发件人: Todd F.
发送时间: 2008-07-23 21:33:04
收件人: [email protected]
抄送:
主题: Re: Re: Fedora 9 / Panic

Using the init.d scripts

Source function library.

. /etc/rc.d/init.d/functions

Source networking configuration.

. /etc/sysconfig/network

Check that networking is up.

[ “$NETWORKING” = “no” ] && exit 0

nginx="/usr/sbin/nginx"
prog=$(basename $nginx)

NGINX_CONF_FILE="/etc/nginx/nginx.conf"

[ -f /etc/sysconfig/nginx ] && . /etc/sysconfig/nginx

lockfile=/var/lock/subsys/nginx

start() {
[ -x $nginx ] || exit 5
[ -f $NGINX_CONF_FILE ] || exit 6
echo -n $"Starting $prog: "
daemon $nginx -c $NGINX_CONF_FILE
retval=$?
echo
[ $retval -eq 0 ] && touch $lockfile
return $retval
}

stop() {
echo -n $"Stopping $prog: "
killproc $prog -QUIT
retval=$?
echo
[ $retval -eq 0 ] && rm -f $lockfile
return $retval
}

restart() {
configtest || return $?
stop
start
}

On Wed, Jul 23, 2008 at 9:15 AM, Chancey [email protected] wrote:

How did you restart nginx ?

2008-07-23

Chancey

发件人: Todd F.
发送时间: 2008-07-23 20:30:09
收件人: [email protected]
抄送:
主题: Re: Fedora 9 / Panic
Hi,

I see this in my error log as well, and it appears to happen only when
I restart nginx… It does mean sometimes the restarts fail.

-Todd

On Wed, Jul 23, 2008 at 1:45 AM, Dylan S. [email protected]
wrote:

I’m getting the following error in the error.log:
panic: MUTEX_LOCK (22) [op.c:453].

nginx -v
nginx version: nginx/0.6.31

uname -a
Linux woot 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64 x86_64
x86_64 GNU/Linux

gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: …/configure --prefix=/usr --mandir=/usr/share/man
–infodir=/usr/share/info
–with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap
–enable-shared --enable-threads=posix --enable-checking=release
–with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions
–enable-languages=c,c++,objc,obj-c++,java,fortran,ada
–enable-java-awt=gtk --disable-dssi --enable-plugin
–with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre
–enable-libgcj-multifile --enable-java-maintainer-mode
–with-ecj-jar=/usr/share/java/eclipse-ecj.jar
–disable-libjava-multilib --with-cpu=generic
–build=x86_64-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC)

Any insight would be appreciated :slight_smile:
Thanks !

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs