Fatal error: The remote end hung up unexpectedly

Hi,
I’d like to create my first ROR application on Heroku but I can’t deal
with one step in this tutorial:
http://devcenter.heroku.com/articles/quickstart
I’ve spent all my day for this and I have no idea what is wrong…

I cannot deal with last one in 3th part -> Create your Heroku
application

What I did:

I’ve installed eveything what I need

switch to the ROOT and go to project directory:
/home/alex/Dokumenty/work/depot/
git init
git commit -m “new app”
1st step DONE

http://help.github.com/linux-set-up-git/ - I use this
tutorial
$ ssh-keygen -t rsa -C “[email protected]
passphrases --> empty
I’ve copied id_rsa.pub into SSH Public Keys in GITHUBE site
$ ssh -T [email protected]
git config --global user.name “girly girl”
git config --global user.email “[email protected]
git config --global github.user girlygirl
git config --global github.token my_token
2nd step DONE

I go to the /home/alex/Dokumenty/work/depot/ and write command :

heroku create --> with result:
Enter your Heroku credentials.
Email: [email protected]
Password:
Creating electric-fog-9780… done, stack is bamboo-mri-1.9.2
http://electric-fog-9780.heroku.com/ |
[email protected]:electric-fog-9780.git
Git remote heroku added

Nextly:
git remote show heroku with result:

The authenticity of host ‘heroku.com (50.19.85.132)’ can’t be
established.
RSA key fingerprint is xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘heroku.com,50.19.85.132’ (RSA) to the list
of known hosts.
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

Any ideas? Pls help me!

Thx in advance

There’s a file inside that folder…
try this I helped me few days ago

http://stackoverflow.com/questions/4269922/permission-denied-publickey-when-deploying-heroku-code-fatal-the-remote-end

It’s because you may have been doing “heroku create” a lot of times
theres a folder .git and inside theres a file config
be sure that its your application name

I supose you’ve followed this tutorial
http://devcenter.heroku.com/articles/rails3
I had that same problem … but I can’t remember where I found
information,
just try google and stackoverflow

I’ve followed this tutorial:
http://devcenter.heroku.com/articles/quickstart

file config in .git looks ok:

[core]
repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true
[remote “heroku”]
url = [email protected]:eerie-meadow-9207.git
fetch = +refs/heads/:refs/remotes/heroku/

And you’re right, I use command create many times…

Well then I’m not sure where the file is
because in that file mentioned a name of another heroku app, that’s why
I
couldn’t upload it
then I changed that and it worked

Ok, I did it and I finished this tutorial but when I run command

heroku open

I see comment:

Application Error

An error occurred in the application and your page could not be

served. Please try again in a few moments.

If you are the application owner, check your logs for

details.

http://eerie-meadow-9207.heroku.com/

What now ?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs