Fat free CRM error

Good day gurus I was trying this fat free crm I was trying now to run
the server it gives me an error

ruby.exe- entry point not found

The procedure entry point sqlite3_column_database_name could not be
located in the dynamic link library sqlite3.dll

I have this versions of instant rails

C:\InstantRails-2.2-win\rails_apps\CRM>ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

C:\InstantRails-2.2-win\rails_apps\CRM>rails -v
Rails 2.3.8

C:\InstantRails-2.2-win\rails_apps\CRM>gem -v
1.3.7

C:\InstantRails-2.2-win\rails_apps\CRM>

whole errors are the following

C:\InstantRails-2.2-win\rails_apps\CRM>ruby script/server
=> Booting Mongrel
=> Rails 2.3.8 application starting on http://0.0.0.0:3000
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:3
1:in gem_original_require': no such file to load -- sqlite3/sqlite3_native (Mis singSourceFile) from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:31:inrequire’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2
.3.8/lib/active_support/dependencies.rb:156:in require' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2 .3.8/lib/active_support/dependencies.rb:521:innew_constants_in’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2
.3.8/lib/active_support/dependencies.rb:156:in require' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1. 3.1-x86-mswin32-60/lib/sqlite3.rb:6 from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:36:ingem_original_require’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:36:in require' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2 .3.8/lib/active_support/dependencies.rb:156:inrequire’
… 69 levels…
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/rails-2.3.8/lib
/commands/server.rb:84
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:31:in gem_original_require' from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:31:inrequire’
from script/server:3

Please advice thanks again

Have you installed the required gems on the server?

David Furber wrote in post #950429:

Have you installed the required gems on the server?

I think I found out that the database.yml was renamed and after running
again the script server. I got another error again sir.

C:\InstantRails-2.2-win\rails_apps\crm2>ruby script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:223:in
activate ': undefined methodmap’ for nil:NilClass (NoMethodError)
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:249
:in activate' from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:248 :ineach’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:248
:in activate' from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:108 2:ingem’
from
./script/…/config/…/vendor/rails/railties/lib/rails/gem_dependenc
y.rb:65:in add_load_paths' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:272: inadd_gem_load_paths’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:272:
in each' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:272: inadd_gem_load_paths’
… 30 levels…
from
C:/InstantRails-2.2-win/rails_apps/crm2/vendor/rails/railties/lib/c
ommands/server.rb:49
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:31:in gem_original_require' from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:31:inrequire’
from script/server:3

C:\InstantRails-2.2-win\rails_apps\crm2>rake db:migrate
(in C:/InstantRails-2.2-win/rails_apps/crm2)
rake aborted!
undefined method `map’ for nil:NilClass

(See full trace by running task with --trace)

Thanks again sir

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs