FastCGI, shebang line options, and library path question

Hello!

I’m trying to configure a simple script to test a ruby/apache/FastCGI
setup
here. I need to specify an alternate library path to the ruby
executable, as
the built-in search path is not sufficient. However, when invoked by
FastCGI, it seems to ignore the -I switch.

Example shebang:

 #!/path/to/bin/ruby -I /path/to/lib/ruby/1.8

This line will run ruby, but the -I option is ignored.

when I run:

 ./ruby -I /path/to/lib/ruby/1.8 -e 'puts $:'

It appends the specified path.

Question: what’s the proper way to specify an alternate library path to
the
ruby interpreter when invoked as a FastCGI script?

Thanks!
-c-

On Thu, 2006-07-20 at 00:58 +0900, Chris Gansen wrote:

Thanks!
-c-

Try setting $LOAD_PATH (or $:) inside the script:

$:.unshift("/path/to/library")

Aria

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs