FastCGI: comm with (dynamic) server dispatch.fcgi aborted

I just did a “gem update” on my server updating to the latest version.
After this none of my scripts work.

In apache error log I get:

FastCGI: comm with (dynamic) server
“/home/user/public_html/dispatch.fcgi” aborted: (first read) idle
timeout (30 sec)

My only guess is that the problem is related to the fastCGI binding but
I have no idea what to look for. I haven’t touched my mod_fastcgi

Running fcgi-2.4.0

These are my gems:

*** LOCAL GEMS ***

actionmailer (1.1.5, 1.0.1, 0.9.1, 0.7.1, 0.6.1, 0.6.0)
Service layer for easy email delivery and testing.

actionpack (1.11.2, 1.9.1, 1.8.1, 1.5.1, 1.4.0, 1.3.0)
Web-flow and rendering framework putting the VC in MVC.

actionwebservice (1.0.0, 0.8.1, 0.7.1, 0.6.0)
Web service support for Action Pack.

activerecord (1.13.2, 1.11.1, 1.10.1, 1.8.0, 1.6.0, 1.5.0)
Implements the ActiveRecord pattern for ORM.

activesupport (1.2.5, 1.1.1, 1.0.4, 1.0.1)
Support and utility classes used by the Rails framework.

fcgi (, 0.8.5)
FastCGI ruby binding.

rails (1.0.0, 0.13.1, 0.12.1, 0.10.1, 0.9.5, 0.9.4)
Web-application framework with template engine, control-flow layer,
and ORM.

rake (0.6.2, 0.5.4, 0.4.15)
Ruby based make-like utility.

RedCloth (3.0.4, 3.0.3)
RedCloth is a module for using Textile and Markdown in Ruby. Textile
and Markdown are text formats. A very simple text format. Another
stab at making readable text that can be converted to HTML.

rmagick (1.9.3, 1.9.0)
RMagick is an interface between the Ruby programming language and
the ImageMagick and GraphicsMagick image processing libraries.

rubygems-update (0.8.11, 0.8.10, 0.8.8, 0.8.6)
RubyGems Update GEM

sources (0.0.1)
This package provides download sources for remote gem installation

Any ideas?

Thanks for your help…

Solved it…
the gem update messed up the fcgi gem for some reason.
I downloaded it and built it manually, then it worked.