Fast CGI


#1

OK, I finally have Apache configured however the app seems very slow. I
am hoping I can speed it up by using fast cgi. I am having not able to
install the fcgi gem. Below is the error I get when I try. Any help on
this subject would be much appreciated.

sudo gem install fcgi -r – -with-fcgi-lib=/usr/local/fcgi/lib
–with-fcgi-include=/usr/local/fcgi/include
Attempting remote installation of ‘fcgi’
Updating Gem source index for: http://gems.rubyforge.org
Building native extensions. This could take a while…
can’t find header files for ruby.
ERROR: While executing gem … (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1 for inspection.
ruby extconf.rb install fcgi -r – -with-fcgi-lib=/usr/local/fcgi/lib
–with-fcgi-include=/usr/local/fcgi/include\n

Results logged to
/usr/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/ext/gem_make.out


#2

On Wed, 2006-05-17 at 19:39 +0200, John W. wrote:

can’t find header files for ruby.
You need to install ruby-dev. How to do that, depends on your
distribution.


Erlend S. removed_email_address@domain.invalid
ClockingIT - http://www.clockingit.com