Faire coexister rails 1.1.6 et 1.2.x


#1

Bonjour,

Est-il possible de faire coexister 2 versions de rails sur un même
serveur ?
Une solution peut consister à “freezer” les version pour chaque appli en
fonction de la version qu’on désire mais existe-t-il une autre méthode ?

Merci

Sam


#2

Le 1 mars 07 à 10:59, Samuel DECHOMETS a écrit :

Bonjour,

Bonjour,

Est-il possible de faire coexister 2 versions de rails sur un même
serveur ? Une solution peut consister à “freezer” les version pour
chaque appli en fonction de la version qu’on désire mais existe-t-
il une autre méthode ?

Oui avoir les 2 gems installé et binder les versions de gems chacune
des applis en définisant la constante RAILS_GEM_VERSION avant le boot
(donc typiquement dans config/environment.rb)

C’est à dire concrètement RAILS_GEM_VERSION = ‘1.2.2’ dans l’un et
RAILS_GEM_VERSION = ‘1.1.6’ dans l’autre. Si la constante n’est pas
définie rails utilise la version la plus récente du gems.

Renaud_______________________________________________
Railsfrance mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.fr/mailman/listinfo/railsfrance


#3

Lorsque tu installes le gem de Rails, il s’installe normalement à côté
des autres versions de Rails.
Il suffit de dire alors à ton appli (dans conf/environment.rb) de quelle
version elle doit dépendre, et s’assurer que le gem avec la bonne
version est présent là où tu la déploies.

++

yk

Samuel DECHOMETS a écrit :


#4

J’avais envisagé la chose mais ça me paraissait trop simple… Honte Ã
moi,
j’ai sous-estimé Rails.

Merci

Sam

Le 01/03/07, Yann K. removed_email_address@domain.invalid a écrit :