Failure to install or update any gem through Win CMD

Hello,

I’ve been trying to install and update different gems to work with Ruby
on Rails, but keep getting the same error, apparently indicating I can’t
install or update any gem:

I generally type in something like:

gem update --system or gem install Rails --version 4.0.0 --no-ri
–no-rdoc

And get the following:

ERROR: While executing gem … (Errno::EINVAL)
Invalid Argument - socket(2) - udp

Note that I’ve proceeded to the same setup just a couple of days before
on a different machine and had no problem.

I couldn’t figure any place where this same Error was explained or
encoutered.

Anybody here can help out?

On Monday, 30 November 2015 08:24:15 UTC-5, Ruby-Forum.com User wrote:

–no-rdoc
encoutered.

The error you’ve described looks a lot like this one:

https://github.com/rubinius/rubinius/issues/2929#issuecomment-34701873

Can you run the script linked there and paste your output?

Since this is (potentially) a networking issue, any information about
your
setup (system version, network config, any proxies in use, etc) would be
useful.

–Matt J.

you’re trying to develop on windows?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs