Failure to build GNU Radio on various Ubuntu builds

Hello, After trying to install GNU Radio over the past few days
I’vebeen unsuccessful due to various failures of GNU Radio to build. The
latest error is as follows:- Segmentation fault (core
dumped)gr-blocks/swig/CMakeFiles/blocks_swig5_swig_doc.dir/build.make:177:recipe
for target ‘gr-blocks/swig/blocks_swig5_doc.i’ failedmake[2]: ***
[gr-blocks/swig/blocks_swig5_doc.i] Error 139CMakeFiles/Makefile2:3254:
recipe for
target’gr-blocks/swig/CMakeFiles/blocks_swig5_swig_doc.dir/all’
failedmake[1]:
***[gr-blocks/swig/CMakeFiles/blocks_swig5_swig_doc.dir/all] Error
2Makefile:147: recipe for target ‘all’ failedmake: *** [all] Error 2make
failedExiting Gnu Radio build/install As mentioned, this is the latest
error of a series ofmany other errors occurring during previous
install/build attempts but whichwould be too numerous to mention
here. I’ve tried installing using Marcus’s script from the ShirleyBay
server but the install fails near the end when attempting to build
asmentioned above. I modified Marcus’s script at one point to get the
install torun more successfully although eventually even that
modification to a line inthe script fails to lead to a successful
overall build but it does appear tobuild further doing that. On this
occasion, I’ve tried various distro’s of Ubuntu(12.04 LTS, 14.04 LTS –
32 bit and 15.04 64 bit) but none accommodate theinstall of GNU Radio
without some error or other. I feel I have installed prerequisites and
so forth andprerequisites from various suggestions in the various
threads on other sitesdiscussing the install of GNU Radio on Ubuntu. I
should say that I’ve installed GNURadio successfully manytimes in the
past, using 12.04 LTS and installing GNU Radio on Windows 7 andthis has
been great to use with my Ettus USRP B100 (using UHD) at the
time.However, today, some two years later I want to use GNU Radio a lot
more andhopefully write modules and develop a SDR UI for my Ettus device
but I don’tappear to be having any success at the GNU Radio install
which is frustrating. I’ve used so much time up trying to overcome the
variousissues, I’m now turning to ask for help as I feel I’ve exhausted
every approachI can try with my present knowledge level. All help and
guidance is very much appreciated and manythanks in advance. Mark.

On Fri, Aug 14, 2015 at 8:42 AM, Mark [email protected]
wrote:

for target ‘gr-blocks/swig/blocks_swig5_doc.i’ failed
As mentioned, this is the latest error of a series of many other errors
On this occasion, I’ve tried various distro’s of Ubuntu (12.04 LTS, 14.04
today, some two years later I want to use GNU Radio a lot more and
Mark.


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Two comments, it’s hard to provide any assistance with this since you
don’t
include any logs so we don’t know what the exact problem is.

However, I suggest you just use the gnuradio that comes packaged in the
latest ubuntu. ‘apt-get install gnuradio’. If you insist on a source
build
then I always like to do at least a apt-get build-dep gnuradio on fresh
OS
installs. (but it’s worth asking yourself if you really need the source
build, especially since it’s causing so much grief)

On 08/14/2015 09:11 AM, West, Nathan wrote:

A further comment–that seg fault is probably the compiler running out
of memory–not very graceful of it, to be sure.

You should add more swap space to make up for lower system memory (how
much do you have?)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs