Failing to install act_as_ferret


#1

I haven’t used ferret in a about a year but before that I had
successfully used acts_as_ferret and it worked well. But I am failing to
get newer versions of the plugin to work.

I installed the latest ferret gem

then the acts_as_ferret gem (this bit was new since I last used it)

then I added require ‘acts_as_ferret’ to enviroment.rb

then I coped aaf_install into my project and ran it

Installing: ferret_server
/usr/local/lib/ruby/1.8/fileutils.rb:1182:in stat': No such file or directory - ./../script/ferret_server (Errno::ENOENT) from /usr/local/lib/ruby/1.8/fileutils.rb:1182:inlstat’
from /usr/local/lib/ruby/1.8/fileutils.rb:1160:in stat' from /usr/local/lib/ruby/1.8/fileutils.rb:1242:incopy_file’
from /usr/local/lib/ruby/1.8/fileutils.rb:459:in copy_file' from /usr/local/lib/ruby/1.8/fileutils.rb:383:incp’
from /usr/local/lib/ruby/1.8/fileutils.rb:1377:in
fu_each_src_dest' from /usr/local/lib/ruby/1.8/fileutils.rb:1393:infu_each_src_dest0’
from /usr/local/lib/ruby/1.8/fileutils.rb:1375:in
fu_each_src_dest' from /usr/local/lib/ruby/1.8/fileutils.rb:382:incp’
from aaf_install:13:in `install’
from aaf_install:19

and when I try to run the normal rails server I get :

~/web_sites/new_early$ruby script/server
=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
/Users/itchy/web_sites/new_early/public/…/config/environment.rb:2:in
`require’: no such file to load – acts_as_ferret (LoadError)
from
/Users/itchy/web_sites/new_early/public/…/config/environment.rb:2
from /Users/itchy/web_sites/new_early/public/dispatch.fcgi:21
2009-03-20 23:34:58: (mod_fastcgi.c.1048) the fastcgi-backend
/Users/itchy/web_sites/new_early/public/dispatch.fcgi failed to start:
2009-03-20 23:34:58: (mod_fastcgi.c.1052) child exited with status 1
/Users/itchy/web_sites/new_early/public/dispatch.fcgi
2009-03-20 23:34:58: (mod_fastcgi.c.1055) if you try do run PHP as
FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing ‘php -v’ and it
should display ‘(cgi-fcgi)’ in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
2009-03-20 23:34:58: (mod_fastcgi.c.1060) If this is PHP on Gentoo add
fastcgi to the USE flags
2009-03-20 23:34:58: (mod_fastcgi.c.1356) [ERROR]: spawning fcgi failed.
2009-03-20 23:34:58: (server.c.834) Configuration of plugins failed.
Going down.
Exiting

any ideas?