Failing Routes in deployment

I have an app that has the following in the routes file:

namespace “admin” do
# ADMINISTRATIVE ROUTES ONLY
root :to => ‘home#index’
resources :comments do
member do
get :approve
get :reject
end
end
resources :users do
member do
get :block
get :unblock
end
end
end

When browing to /admin locally, I am greeted by the appropriate page.
On the same URL on the heroku version I get a 404. The route shows
correctly in ‘heroku rake routes’

Logs are showing:

ActionController::RoutingError (wrong constant name Admin/
homeController):
/disk1/home/slugs/196384_c95a9e3_4463/mnt/.bundle/gems/gems/
activesupport-3.0.0.beta4/lib/active_support/inflector/methods.rb:
103:in `const_defined?’

Any ideas?

Anyone? From what I can see from the guides, what I am doing here is
correct (http://guides.rails.info/routing.html#controller-namespaces-
and-routing)

Does anyone have any pointers?

I have exactly the same problem, works locally (osx) but when deployed
to Heroku I get a similar error has Neil has detailed above

Rails 3 b4.

John.

It seems to be dependent on the environment the application is running
in, development seems to work, I’m seeing a routing failure locally in
production mode the same as Neil details above and also a ‘staging’
environment that I’m also running on Heroku

turns out to be nothing to do with Heroku…pointing the finger too
early :slight_smile:

Seems to be a problem with Rails 3 Namescope routes (/admin) and the
right_aws gem declared in both a production and staging environment in
the Gemfile.

John.