Failing rake task

I’m running rspec and rspec on rails in svn external so I am running
the latest version of the trunk. Recently the rake spec task started
braking the continuous integration server because the rake aborted. I
checked my local and it ran with the same behavior… and all of the
devs on my team are now experiencing the same problem. All the spec’s
are passing, but the rake task is aborting. Anyone know why this could
be happening?

Finished in 8.396101 seconds

422 examples, 0 failures, 25 pending
rake aborted!
Command ruby etc. etc.

" --options “/Users/lance/Sites/feedvuz/spec/spec.opts” failed

(See full trace by running task with --trace)

The trace produced the following results:

" --options “/Users/lance/Sites/feedvuz/spec/spec.opts” failed
/Users/lance/Sites/feedvuz/vendor/plugins/rspec/lib/spec/rake/spectask.rb:173:in
define' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:823:inverbose’
/Users/lance/Sites/feedvuz/vendor/plugins/rspec/lib/spec/rake/spectask.rb:142:in
define' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:incall’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in
execute' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:ineach’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in
execute' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:ininvoke’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in
synchronize' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:ininvoke’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in
top_level' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:ineach’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in
top_level' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:instandard_exception_handling’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:in
top_level' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:inrun’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
standard_exception_handling' /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:inrun’
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
/usr/bin/rake:16:in `load’
/usr/bin/rake:16

Thanks in advance!
-L

Try re generating the rspec files:

ruby script/generate rspec

-Matt


--------
http://railsontherun.com

Looks like a bunch of updates were made overnight to the rake task and
it works now. Serves me right for wanting to be on the edge. :slight_smile:

Yea I tried that already, I will try again, but i replaced my local
files and checked the diff on the repo. I didn’t see any changes in
the new files that would have any effect on the rake task. It updated
spec.opts and spec_helper… I have stuff in spec_helper that is
application specific that showed in the svn diff (but nothing else)
and there were subtle changes in spec.opts … I will try again but, I
remember still having problems.

-L

On Nov 21, 2007 2:12 AM, Lance C. [email protected] wrote:

I’m running rspec and rspec on rails in svn external so I am running
the latest version of the trunk.

revision?

On Nov 21, 2007 6:11 PM, Lance C. [email protected] wrote:

I’m at the very latest, not sure what that is, but I just updated and
pulled down a bunch of new files related to the rake task and
everything is working fine now.

For the future: svn info vendor/plugins/rspec

I’m at the very latest, not sure what that is, but I just updated and
pulled down a bunch of new files related to the rake task and
everything is working fine now.