Failed to load Rails: Could not find RubyGem jruby-openssl

Hi,
I am new to Rails.I am trying to run rails application in Tomcat.
I am getting the fallowing error.

INFO: Failed to load Rails: Could not find RubyGem jruby-openssl (>=
0.0.0)

But I have installed JRuby-openssl . It is not packing JRuby-openssl.gem
while making the war file.

Can anybody tell me please?

Thanks

Bharath.

Jan 23, 2008 3:38:26 PM org.apache.catalina.core.ApplicationContext log
INFO: Failed to load Rails: Could not find RubyGem jruby-openssl (>=
0.0.0)

    C:/Tomcat-5.5.12/webapps/Workorders/WEB-INF/gems/gems/rails-2.0.2/lib/in

itializer.rb:159:in require_frameworks' C:/Tomcat-5.5.12/webapps/Workorders/WEB-INF/gems/gems/rails-2.0.2/lib/in itializer.rb:88:inprocess’
C:/Tomcat-5.5.12/webapps/Workorders/WEB-INF/gems/gems/rails-2.0.2/lib/in
itializer.rb:49:in send' C:/Tomcat-5.5.12/webapps/Workorders/WEB-INF/gems/gems/rails-2.0.2/lib/in itializer.rb:49:inrun’
C:/Tomcat-5.5.12/webapps/Workorders//config/environment.rb:20
:1

javax.servlet.ServletException: Could not load Rails. See the logs for
more deta
ils.
at
org.jruby.webapp.RailsFactory.makeObject(RailsFactory.java:137)
at
org.jruby.webapp.util.CustomObjectPool.addObjectInternal(CustomObject
Pool.java:111)
at
org.jruby.webapp.util.CustomObjectPool.access$200(CustomObjectPool.ja
va:15)
at
org.jruby.webapp.util.CustomObjectPool$PoolSizeManager.run(CustomObje
ctPool.java:193)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs