Failed to install Ruby on Rails

Greetings,

I am facing problem when installing the rails 2.1.0. i have saved the
gem file in the bin folder, but it always come out with the error saying
that rails require rake 0.8.1. I try to download the rake gem file, but
also failed to install it. i have tried the command " gem install rails
–include-dependencies" but error pop up saying that target machine
refused to activate it.

May i know is there any other way for me to install rails?

Thanks a lot.

Could you copy and paste the exact error please?

Ryan B. wrote:

Could you copy and paste the exact error please?

Sorry for not being clear.
Below are the errors that i see.

  1. when using command ‘gem install rails’
    ERROR: While executing gem … (RuntimeError)
    Error instaling rails:
    rails requires rake >= 0.8.1

  2. when using command ‘gem install rails --include-dependencies
    –remote’
    ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
    No connection could be made because the target machine actively
    refused it.

  • connect(2)(Errno::ECONNREFUSED)
  1. when istalling rake ‘gem install --remote rake’
    ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
    No connection could be made because the target machine actively
    refused it.
  • connect(2)(Errno::ECONNREFUSED)

thanks again…

Ryan B. wrote:

What does “gem sources” give you?

This is what i get…

*** CURRENT SOURCES ***

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
No connection could be made because the target machine actively
refused it.

  • connect(2)(Errno::ECONNREFUSED)

May i know is that anything that i miss out and have not save yet?
Previously I am using the ruby 1.8.6. one click installer to istall the
ruby and gem.
Thanks.

What does “gem sources” give you?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs